This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by katrienP 1 year ago.

Assigned support staff: Lauren.

Author Posts
October 13, 2018 at 12:32 am

katrienP

I am trying to: go to the English checkout page when I am logged out

Link to a page where the issue can be seen: hidden link

I expected to see: the English checkout page

Instead, I got: the Dutch cart page

October 13, 2018 at 10:20 am #2813991

katrienP

Hello again,
I want to give some more information: the problem only appears for visitors, not for people who are logged in. In the Dutch part of the site everything is running fine.

I have changed the Theme to Store Front and the issue still remains. After switching back I have disabled all the plugins (except woo commerce) and then the English checkout page was working. As soon as I enable the WPML-plugin the issue appears again.

I hope you can help! Thanks and keep up the good work!
Katrien

October 15, 2018 at 3:03 pm #2818022

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

I just submitted an test order on your site in English under the username WPML TEST. Here are the steps I took:

1. Add an English product to the cart
2. View Cart
3. Continue to checkout. It brought me to the payment page.

Can you please tell me what is not working on your checkout page? Are you getting any specific error messages? Am I following the same steps above that you are? I made sure that I was not logged in when conducting this test.

To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.

NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

October 19, 2018 at 10:03 am #2831501

katrienP

Hello Lauren, thank you so much for your help! And yes, you did exactly what I did and it is not working for me. I do not get an error. I just can not reach the English cart or checkout. Every time the Dutch cart and checkout is showing. The url is also changing from theswedishgiftshop/en/cart to theswedishgiftshop/winkelwagen. And this happens on my iPhone, iPad and Mac when I am logged out. Very strange.
Thanks again for checking,
Katrien

October 19, 2018 at 7:38 pm #2832896

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Strange that it is not happening for me. I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentySeventeen. With these settings, is the issue resolved? If so, please activate your plugins one at a time and then reactivate your theme to see if we can figure out what is causing the conflict.

October 22, 2018 at 2:56 pm #2838531

katrienP

Hello Lauren,
I did what you suggested and the issue is not solved. The url hidden link is redirecting to hidden link when I change the theme to TwentySeventeen and deactivate all plugins except the WPML related.
Please, can you check as soon as possible what is wrong and solve this? I lose customers every day and get e-mails that they are not able to go to checkout.
Thank you!

October 22, 2018 at 4:36 pm #2838986

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Is there a particular product you are adding to the cart when this is happening? I am still not able to reproduce the issue. I also asked some of my peers to check and they also were able to get to the English checkout page without being redirected.

I did log in to your site and went to WPML -> Languages and scrolled down to the Language Filtering for Ajax section. I checked the box to enable "Store a language cookie to support language filtering for AJAX". Please clear your browser cache or view the site in an incognito browser. Are you still being redirected to the cart page in English?

October 23, 2018 at 6:55 am #2841098

katrienP

Hello Lauren, I always use different products when I am trying to found out what the problem is. Are you sure that you are logged out? When logged in the issue is not showing. Can you send me a printscreens with the url when you get to the English checkout?
It is unfortunately not working after clearing the browser cache.

October 23, 2018 at 1:14 pm #2842513

katrienP

Hello Lauren, I have found the problem. It was the caching of the server at the hosting. They have solved it by excluding the checkout page from chatting.
Thanks again for the support!
Katrien

October 23, 2018 at 1:14 pm #2842514

katrienP

My issue is resolved now. Thank you!