This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 11.09 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: The Chinese flag is not displaying correctly, it is missing or corrupt.

Solution: I have fixed this issue by uploading Chinese flag again from WPML >> Languages >> Edit Languages >> Custom Flag option.

This topic contains 6 replies, has 2 voices.

Last updated by chrisC-37 5 months, 1 week ago.

Assigned support staff: Noman.

Author Posts
May 9, 2019 at 9:42 am #3774717

chrisC-37

The Chinese flag is not displaying correctly, it is missing or corrupt. see screen shot.

May 9, 2019 at 9:44 am #3774767

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML support.

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

May 9, 2019 at 12:27 pm #3776101

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have fixed this issue by uploading chinese flag again from WPML >> Languages >> Edit Languages >> Custom Flag option. And now it showing correct flag as you can see in the attached screenshot.

Thank you

May 9, 2019 at 12:34 pm #3776139

chrisC-37

Great thanks.

I assume you manually uploaded a flag using the Custom Flag option.
If I experience a similar issue again with a missing WPML default flag, where can I find all of the WPML flag icons so I can upload it manually using the Custom Flag option.

Cheers,
Anthony.

May 9, 2019 at 2:00 pm #3776853

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

You can find all flags within this plugin folder:
/wp-content/plugins/sitepress-multilingual-cms/res/flags/

Thank you and have a great day.

May 9, 2019 at 2:02 pm #3776893

chrisC-37

Brilliant, thanks!

May 9, 2019 at 2:03 pm #3776901

chrisC-37

My issue is resolved now. Thank you!