Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 1 reply, has 2 voices.

Last updated by Marcos Vinicios Barreto 1 month, 3 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
March 11, 2021 at 2:28 pm #8285965

borisB-22

If you click on hidden link and switch to CN it takes ages to load the page, where other languages work well.
At the end page loads in English even though it's switched to Chinese
If language is switched on subpages to CN it works fine

March 11, 2021 at 11:41 pm #8289591

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting our support service. I took a look at your homepage and noticed the loading issue when switching to the chinese language, before a more detailed look, please, try the following:

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

1 - Proceed to your WordPress Dashboard > WPML > Support click the 'Troubleshooting' link and perform these actions:

  • Clear the Cache in WPML
  • Remove ghost entries from the translation tables
  • Fix element_type collation
  • Fix WPML table collation
  • Set language information
  • Cleanup and optimize string tables

2 - If it doesn't help, try disabling all the plugins except the WPML related ones and enable one plugin at a time untill the possible culprit one is found.

Please, let me know the results, have a nice day.