This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.89 hours from now. Thank you for your understanding.

This topic contains 8 replies, has 2 voices.

Last updated by Harshad 6 years ago.

Assigned support staff: Harshad.

Author Posts
October 11, 2013 at 3:57 pm #275954

Timothy

Hi, I created a post with chinese characters as the title and I have permalink activated to /%postname%/

The webconfig file is as follows:

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
  <system.webServer>
    <rewrite>
      <rules>
			<rule name="wordpress" patternSyntax="Wildcard">
				<match url="*"/>
					<conditions>
						<add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true"/>
						<add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true"/>
					</conditions>
				<action type="Rewrite" url="index.php"/>
			</rule></rules>
    </rewrite>
  </system.webServer>
</configuration>

When I click on the link to view the post it then jumps to the page:
hidden link

Is there anything I am missing in the WPML configuration?

October 12, 2013 at 6:34 am #276098

Harshad

Dear Timothy,

Are you on IIS 6? Does your host support ASAPI_Rewrite?

Please check the links below
hidden link
http://codex.wordpress.org/Using_Permalinks

October 12, 2013 at 6:47 am #276099

Timothy

Hi Harshad,

I already installed the rewrite module for the IIS I am able to navigate to pages without using page ID. For example, hidden link works with the permalink activated.

October 12, 2013 at 8:22 am #276122

Harshad

Dear Timothy,

Does the post page works when you disable WPML and addon plugins

October 12, 2013 at 8:40 am #276130

Timothy

I have WPML and all the plugins activated and the permalink works. The only thing that doesn't work is when the url is encoded with chinese characters then the link will turn into:

hidden link

October 12, 2013 at 8:54 am #276137

Harshad

Dear Timothy,

Yes, I am asking if the encoded url work when you disable WPML?

October 12, 2013 at 5:12 pm #276225

Timothy

I just tried it and it works having the permalink in chinese characters but when I activate wpml it doesn't work.

October 13, 2013 at 10:20 am #276314

Harshad

Dear Timothy,

Can you please send me your ftp and wordpress admin details to harshad.m@wpml.org?

Please include this forum link for reference.

October 16, 2013 at 11:21 am #277919

Harshad

Dear Timothy,

Sorry for delay, Can you please give a try now I tried to change the slug of News page in Chinese Traditional, I was able to browse the news page with following url.
hidden link

The topic ‘[Closed] Chinese URL Encoding Problem’ is closed to new replies.