This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
June 22, 2019 at 5:14 pm #4071343

Michael

Our site default WPML language is English. However, prior to WCML 4.6.5 we've been always receiving WooCommerce admin e-mails ("new customer order", for example) in our second language, Russian. Since 4.6.5 they arrive in English. I've read this in 4.6.5 changelog: «Use default language if admin user not exists while sending "New Order" email to admins». What does this mean? How do we choose language for WooCommerce admin e-mails now? We would like to return to Russian.

Thanks.

June 24, 2019 at 10:55 am #4076717

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will help you with the issue.

In order to receive WooCommerce admin e-mail in a specific language
- Goto Users -> Your profile
- Scroll down to Languages -> Select the language in which you want to receive Emails and save changes

Please note this will change the dashboard language as well. Please let me know if that helps.

Kind regards
Raja

June 26, 2019 at 7:01 am #4089695

Michael

Thank you for your reply. I did change the admin user language. Dashboard language has indeed changed. However, New Order e-mails are still come in default WPML language.

June 26, 2019 at 1:39 pm #4092839

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Please share temporary access to your site, I can have a closer look into the issue. I have enabled private fields for you to securely share the details.

Kind regards
Raja

July 1, 2019 at 7:13 pm #4122015

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for your patience,

I have checked your site in detail, The woocommerce emails are sent to a mail id which is not associated with any of the Admin user accounts in your site.

The emails sent to the admin will be sent in the admin default language. Since your site default language is English the order emails are sent in English since the mail id is not associated with any of the admin email ids.

If you prefer to receive emails in the Russian language change the mail id in WooCommerce > Settings > Emails to the mail id associated with a site administrator account and set the admin language as Russian.

I hope this helps you better

Kind regards
Raja

July 1, 2019 at 7:43 pm #4122041

Michael

Thank you for the explanation. Can I do vice versa – create another user with e-mail address which is currently set in WooCommerce and set his language to Russian? Does this user has to be Admin or can his role be just a User? Or Shop Manager?

July 2, 2019 at 5:15 am #4124075

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Shop Manager role for the mail id will do the job for you, make sure to set the language of the user from the user profile.

Kind regards
Raja

July 2, 2019 at 5:36 am #4124113

Michael

Understood! Thank you for your help!