This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 7.00 hours from now. Thank you for your understanding.

This topic contains 12 replies, has 3 voices.

Last updated by berryP-2 1 year, 3 months ago.

Assigned support staff: Bruno.

Author Posts
May 21, 2018 at 8:28 pm #2204149

berryP-2

I had WPML running without any problems on my dev and live site. Since the site is waiting to be launched and I am waiting for some things I didn't check for a while.

I just copied my local db to live (like I always do) and tried to check the site, but now I couldn't access the live site (on dev it works, but live is an exact copy of dev through composer/git) and it throws this error:

Fatal error: Uncaught Error: Class 'OTGS_Installer_WP_Share_Local_Components_Setting' not found in /home/user/site.com/public/content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-wp-installer.php:1179

I checked, the file (class-otgs-installer-wp-share-local-components-setting.php) which contains the class exists so that can't be it.

Any idea what can cause this ?

I define my key through a constant in wp-config.php. I don't think it's set through the setting in the plugin. If it is, can it cause issues at another (live) domain ?

PS the debug info is from dev since the plugin won't activate without problems on live.

May 22, 2018 at 7:11 am #2205424

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello there,

Welcome to WPML support forum.

While one of my teammates takes care of your case I will provide you with the first debugging steps.

Could you uninstall and install your WPML package manually?

============================
==>Backup your website and database <==
============================

-Deactivate and delete the “installer” plugin (if you have it).
-Deactivate all WPML plugins.
-Login via FTP to your wp-content/plugins/ folder.
-Delete all WPML folders.
-Go to http://wpml.org/my-account/downloads/ and download the latest WPML Multilingual CMS Plugin, then extract it.
-Upload the plugin via FTP to wp-content/plugins/ folder.
(alternatively you could upload the .zip folder using Dashboard > Plugins > new > upload)
-Activate the WPML plugin via WP Dashboard > plugins.
-Complete the setup, if needed.
-Register WPML for your site (at the end of setup, click on “generate key” button).
-Navigate to Dashboard > Plugins and locate WPML Multilingual CMS.
-Click on the blue link that says “Registered”.
-Download and activate all needed WPML AddOn Plugins.

This should not generate any problems.

In case you want to register WPML for your site manually please make sure to enter the naked URL of your site in wpml.org (something like hidden link)

In the extreme case, please try to register with all non-WPML Plugins deactivated.

Let us know if it helps.
Andrés

May 22, 2018 at 7:26 am #2205494

berryP-2

Thanks for the reply. I tried uninstalling several times, both manual and through composer. No luck. I also deactivated all necessary plugins, but no avail.

May 22, 2018 at 8:51 pm #2211701

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello there,

I would like to take care of your ticket from now. Thanks for following Andrés's instructions, in that case, I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please let me know exactly what steps should I follow to see the problem.

*** Please, can I install the Duplicator or All in One Migration plugin to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

May 23, 2018 at 7:10 am #2212932

berryP-2

I am sorry, I can not give you that. Our server is managed by composer and not accessible through FTP. Any info you wanna know I can give you but access is not part of this.

May 23, 2018 at 11:03 pm #2218921

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

I understand. Unfortunately, I do not know why this problem is happening. It should be necessary to test this and debug it to know why this is happening.

It should be necessary to look at the file permissions, disable all plugins and switch to the default theme, remove all WPML files and install it again (if it does not work through Plugins > Add New, send files via FTP, for example).

Unfortunately, without access to the server nor WP and with no problem like this in our records previously reported, I'm not sure if this is indeed a bug or if that is some compatibility issue on your side.

Perhaps another suggestion should be for you to try, in your test environment, to install WPML (not on your production server). That way you could check if WPML is working properly. Or even, try to install WPML into a subdirectory in your server to test on a new installation (e.g.: yoursite.com/demo/).

Please, let me know. I'll contact 2nd tier support in the meantime.

Thank you.

May 24, 2018 at 8:28 am #2220620

berryP-2

I appreciate the support, but I am a developer for over 10 years. The things you mention are all 'checked' before I even contacted you. I reinstalled the plugin several times, deleted all settings, deactivated all plugins etc.

It has worked fine for ages, hence why I was so surprised it stopped working and I checked all commits since the last time it worked, nothing seems to be able to interfere with WPML.

May 24, 2018 at 1:00 pm #2222809

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

I noticed that in your first post you posted: I define my key through a constant in wp-config.php. I don't think it's set through the setting in the plugin.

Talking with 2nd tier support, they suggested removing (or commenting out) the WPML keys/Toolset keys directly from the wp-config.php file to test.

Then you can register your site following the standard steps (Plugins> Add New > Commercial (tab)).

After following these steps, please let me know if the problem persists.

Thank you.

May 25, 2018 at 9:41 pm #2231797

berryP-2

I have removed the constant from wp-config.php and didn't define it anywhere (since I can't activate the plugin).

After trying to activate it I get this error in my debug log.

PHP Warning:  require(/home/user/doma.in/public/content/plugins/sitepress-multilingual-cms/inc/functions-helpers.php): failed to open stream: No such file or directory in /home/user/doma.in/public/content/plugins/sitepress-multilingual-cms/sitepress.php on line 44
PHP Fatal error:  require(): Failed opening required '/home/user/doma.in/public/content/plugins/sitepress-multilingual-cms/inc/functions-helpers.php' (include_path='.:/usr/share/php') in /home/user/doma.in/public/content/plugins/sitepress-multilingual-cms/sitepress.php on line 44
PHP Warning:  require(/home/user/doma.in/public/content/plugins/sitepress-multilingual-cms/inc/functions-helpers.php): failed to open stream: No such file or directory in /home/user/doma.in/public/content/plugins/sitepress-multilingual-cms/sitepress.php on line 44
PHP Fatal error:  require(): Failed opening required '/home/user/doma.in/public/content/plugins/sitepress-multilingual-cms/inc/functions-helpers.php' (include_path='.:/usr/share/php') in /home/user/doma.in/public/content/plugins/sitepress-multilingual-cms/sitepress.php on line 44
PHP Warning:  require(/home/user/doma.in/public/content/plugins/sitepress-multilingual-cms/inc/functions-helpers.php): failed to open stream: No such file or directory in /home/user/doma.in/public/content/plugins/sitepress-multilingual-cms/sitepress.php on line 44
PHP Fatal error:  require(): Failed opening required '/home/user/doma.in/public/content/plugins/sitepress-multilingual-cms/inc/functions-helpers.php' (include_path='.:/usr/share/php') in /home/user/doma.in/public/content/plugins/sitepress-multilingual-cms/sitepress.php on line 44

It seems to me WPML_PLUGIN_PATH can't be found/is not defined because the file exists and is equal in file size to dev (where it's working).

Dumping WPML_PLUGIN_PATH (on dev) gives me the correct folder.

This is what I have defined in my wp-config.php

    if ( !defined( 'ABSPATH' ) ) {
        define( 'ABSPATH', dirname( __FILE__ ) . '/cms/' );
    }
    define( 'WP_HOME', '<em><u>hidden link</u></em>' . $_SERVER['HTTP_HOST'] );
    define( 'WP_CONTENT_DIR', realpath( ABSPATH . '../content/' ) );
    define( 'WP_CONTENT_URL', WP_HOME . '/content' );
    define( 'WP_SITEURL', WP_HOME . '/cms' );
May 25, 2018 at 9:58 pm #2231804

berryP-2

I just dumped WPML_PLUGIN_PATH on line 44of sitepress.php (before the require).

That gives me:

/home/user/doma.in/public/content/plugins/sitepress-multilingual-cms

which is what I expected.

Server runs on Nginx btw, but it has worked before and the server didn't change...

May 25, 2018 at 10:08 pm #2231817

berryP-2

I just deleted the plugin (which in my opinion also should have deleted all the settings). I then uploaded the zip manually through the add new option. That seems to work. I could activate the plugin and it seems to behave as it should.

It does wonder me what the issue was... Because I don't want to have to upload the plugin manually each time an update comes 🙂

Note: I ticked "I still need help" but I don't think it's still needed, but wanna keep it open for a bit just in case I encounter something.

May 29, 2018 at 2:40 am #2242646

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

I'm glad this is working right now.

Sure, we can keep the ticket open. Please note that after a few days with no new posts, the topic is closed automatically.

Please, let me know if I can help with any other questions you may have. I'll be happy to help.

Thank you.

June 5, 2018 at 7:17 am #2272760

berryP-2

Everything seems to (stay) ok.