This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 3 months, 3 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
June 12, 2019 at 12:34 pm #4004369

gregorE

Hi,

I am running a site hidden link in 5 different languages with WPML (directories). Default language is now English.

Before we switched to directories we have been using TLD for each language with WPML. Default language was Slovenian on hempika.si. All pages were made in Slovenian and translate to other languages later.

Also, I need to mention that we use Flatsome theme that is somehow not listed on the list of supported themes by WPML anymore.

I've encountered some problems.

1. When translating pages via Classic translator sometimes my content gets overwriten by original (in that case Slovenian), even if everything is 100% translated. If I go to that translated page and click "edit anyway" I can paste the translation there and everything works fine. Please let me know how to fix this issue. Do I need to "copy from original" in classic translator and translate all pages all over or is there any other trick I can do to fix this?

I found that also original edited content (with Flatsome page builder) is not shown in classic translations. If I make a new page with page builder and than translate it to different languages with Classic Translation Editor everything works fine.

2. When adding a new language (Croatian) my Woocommerce translations don't automaticaly show up in cart, checkout, etc. Its working fine in Slovenian, Finish, Italian, etc. Do I need to use auto register strings for translations or not?

3. I don't see images of some transtlated products in the backend. But some older products has images in all languages. Thats weird to me. It's working fine on the frontend. How can I fix this issue and how to delete multilingual media most efficiently? I would need only one image available in all languages but with ability to translate their title, alt, etc.

I know that I have a lot of questions but I would like to fix the issues and optimize and speed up the process before I start to add new languages. I am planning on adding 10 more languages so 15 in total.

Thank you 🙂

June 12, 2019 at 7:31 pm #4007367

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Before reply all your questions, I would need to give a further look in your WordPress Dashboard, in order to understand which current settings you have and what is happening, for that, please consider: I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

June 14, 2019 at 7:07 pm #4023827

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a detailed look in your WordPress Dashboard and in order to begin our investigations process, please, consider the points below:

1 - "When translating pages via Classic translator sometimes my content gets overwriten by original (in that case Slovenian), even if everything is 100% translated".

The source of this issue seems to be related with the default language changing. You have changed your default language to english, so in this case, the 'original' language now is english, right? Do you see this behavior in all the pages, a specifici page? Does it happen in all the languages, a specific lanagugage? In some cases, when you have a duplication of your default language page to the secondary language pages and you make a editing to the default language page you will see the content of your secondary pages to be overwritten as they keep in synchronization, in this cases you should make sure you have an independent content translation instead of content duplication. See: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/

1.1 - "I found that also original edited content (with Flatsome page builder) is not shown in classic translations."

Do you refer to the shortcode fields to be translated using the WPML Translation Editor? If so, please, create a test page in english (your default language now) and edit its content using your theme page builder, after that, please add a translation for it and let me know if you see the page builder shortcodes available for translation in the WPML Translation Editor. Also, keep in mind as the Flatsome is not compatible with WPML you can face some issues when trying to translating its content using WPML Translation Editor, in these cases, the best way is to try a manual translation editing the page content using the default WordPress page/post editor for all the languages.

See: https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

As regarding your WooCommerce products translation issues, I kindly ask you to open a new ticket, so we can deal specifically with this issue and this way make it easier for our customers to find solutions for their issues on a topic basis.

Please, let me know if you need any additional clarifications. Have a nice day.

June 17, 2019 at 7:43 am #4032859

gregorE

Correct. The default language is English now. I see the same behaviour on all pages that were created in Slovenian before changing the default language form Slovenian to English.

If I create a new page with a page builder or not (don't mater in which language) everything works fine when using classic translation editor.

If I make a change on "old" original pages I don't see those changes in the clasic translation editor. It shows as 100% translated. For newly created pages it works fine.

June 18, 2019 at 7:09 am #4040869

gregorE

If I disable translation management for all site content and resave pages translations marked with spinning wheels icon and update arrow icon (and get a pencil icon) I can edit every translation as a separate page with no problem.

June 19, 2019 at 4:53 pm #4053523

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates and sorry for the bit of waiting here. In this case, I recommend you to edit your already created pages using the default WordPress page/post editor to keep your translations and then to use the WPML Translation Management for your newly created pages. This is the easier way to keep your translations working for now as you have changed default languages with a bunch of of translations already in place.

See: https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

Please, let me know if it helps, have a nice day.