Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: We were asked to add the Russian language. We thought it was a good idea to change de default language to English to take advantage of the fallback feature of WPML because russian people will more likely understand English then Italian if a page in Russian is missing, but to not change all the permalinks, we stop and immediately went back to Italian as default language. Probably this change made some mess around because since that moment something started not working in the right way. We thought the little problem we face were consequence of a new release not working fine ... but probably is because of the default language change.

Solution: Thanks to Carlos suggestions, I decided to purge the cache and disable all the caching system on the production instance BEFORE clone the website into the staging copy. In this way everything started working ad expected, included the Translation Editor.

Relevant Documentation:

This topic contains 13 replies, has 2 voices.

Last updated by Carlos Rojas 1 year, 4 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 4, 2018 at 6:00 pm #2464619

andreaC-50

I am trying to:

I need to clean other errors in my WordPress-WPML website and translate the home page in Russian.

The original website was in Italian and then we add the English language, translating all the pages (WP+Beaver Builder), products (WooCoomerce) and templates (Beaver Theamer)

Then we were asked to add the Russian language. We thought it was a good idea to change de default language to English to take advantage of the fallback feature of WPML because russian people will more likely understand English then Italian if a page in Russian is missing, but to not change all the permalinks, we stop and immediately went back to Italian as default language.
Probably this change made some mess around because since that moment something started not working in the right way. We thought the little problem we face were consequence of a new release not working fine ... but probably is because of the default language change.

Now we fix some errors with this ticket
https://wpml.org/forums/topic/delete-strings-in-the-text-domain-with-wpml-string-translation-disabled/

But still we need to clean up more things.
We want to translate part of the website in Russian and for the pages not translated we want to show an english page. Because the fallback will point to Italian (default language), we have duplicated all the English pages in Russian and then translate the most important in Russian.

Between the pages we have duplicated there was also the Home Page, but for this page we prefer to translate it from the Italian

Now if we open the Home page with the WordPress Editor we see a lot of errors in the sidebar in the Language section (image "Home - edit page - errors.JPG")

If we clic the plus symbol on the Russian column to add the Russian translation the WPML Translation Editor open showing that we are translating from Italian (orginal) to Russian, but some fileds of the original contente are taken from the English version of the page (see image "Translation Editor - Italian to Russian - Home - fields in English.JPG") while the most of them come from the italian version of the page (image "Translation Editor - Italian to Russian - Home - fields in Italian.JPG")
In the image "Home - edit page - Yoast fileds in italian.JPG" you can see that in the italian version of the home page, the fields that the translation editor shows in English are, as they shoud be, in Italian.

Other info:

  • In WPML->Translation Management the page Home is set as "Russian: waiting for transaltion" (image "Translation management - Home - Russian waiting for translation.JPG")
  • In WPML -> Translations for the Home page there is a translation job from English to Russian (image "Translations - Home - English to Russian - Waiting for translator.JPG") that I would like to remove, because we prefer to translate the page from Italian
  • probably for the previous item, the plus symbol near the page "Home" in the all pages list, say "Edit the Russian translation" instead of "Add translation to Russian" like all other plus symbols(image "Pages - Home - plus equal edit.png") and if I try to duplicate the page from Italian is says "Can't create duplicate. A translation is in progress (image "Home - edit page - cant create duplicate translation in progress.JPG")

    How can I:
    - clean these errors
    - cancel the translation job of the "Home" page from English to Russian
    - start a new translation from Italian to Russian for the page "Home"

    Thank you
    Andrea

  • July 6, 2018 at 9:13 pm #2471868

    Carlos Rojas
    Supporter

    Languages: English (English ) Spanish (Español )

    Timezone: Europe/Madrid (GMT+01:00)

    Hello Andrea,
    Thank you for contacting WPML support.

    I would like to ask you to follow this steps in order to isolate the cause of the issue:
    - Back up your site first before making any change, this is for security reasons.
    - Deactivate all the plugins that are not related to WPML.
    - Switch for a moment to a WordPress default theme like Twenty Seventeen.
    - If the issue is gone, activate one by one to see with which one there is an interaction issue.

    Could you tell me the result of this steps?

    Kind regards,
    Carlos

    July 7, 2018 at 7:01 am #2472107

    andreaC-50

    Hi Carlos,
    thank you for your help.

    I switched to theme Twenty Seventeen

    I deactivated all the plugins that are not related to WPML.
    The plugins active are:

  • WPML CMS Nav
  • WPML Multilingual CMS
  • WPML String Translation
  • WPML Translation Management
  • But nothing change.
    I still get the errors "Warning: mysqli_real_escape_string(): Couldn't fetch mysqli in /home/xxxxxxx/staging/1/wp-includes/wp-db.php on line 1102 ...." in the language section in the edit mode of page "Home"
    and everything I described before

    I trying to build a Duplicator clone, but I need the assistance of the hosting provider to do it because is a staging instance of the website.
    If you need it, I can provide also an administrative account on this instance

    Ciao
    Andrea

    July 9, 2018 at 9:58 am #2475752

    andreaC-50

    In caso of need, I'm ready to post a duplicator package and an administrative account

    July 9, 2018 at 1:47 pm #2476521

    Carlos Rojas
    Supporter

    Languages: English (English ) Spanish (Español )

    Timezone: Europe/Madrid (GMT+01:00)

    Hi Andrea,
    Thank you very much for your feedback.

    Yes, in this case the best option will be if you could share a download link with a copy of the site (Duplicator package). please don't forget to share the installer.php file and the compressed .zip file.

    I have set your next answer private, there you will be able to share the credentials of the live site and the download link with the Duplicator package.

    Looking forward to your answer.
    Best regards,
    Carlos

    July 9, 2018 at 8:12 pm #2477710

    Carlos Rojas
    Supporter

    Languages: English (English ) Spanish (Español )

    Timezone: Europe/Madrid (GMT+01:00)

    Hi Andrea,

    Could you double check the password for the WP user? I couldn't log in the site.

    Best regards,
    Carlos

    July 9, 2018 at 8:48 pm #2477830

    andreaC-50

    Sorry, I made a mistake.
    I updated the wordpress user and wordpress pwd in the private message above
    Ciao
    Andrea

    July 9, 2018 at 9:05 pm #2477852

    Carlos Rojas
    Supporter

    Languages: English (English ) Spanish (Español )

    Timezone: Europe/Madrid (GMT+01:00)

    Hi Andrea,

    The cause of the issue was that the Memcached was enable in SG Optimizer plugin. I dectivated the Memcached option and now the site seems to be working correctly.

    Could you confirm that the issue is solved?

    Note: The content in English in the Translation Editor will be fixed when you translate the homepage again from Italian to English and make sure the translation is 100% completed.

    Best regards,
    Carlos

    July 9, 2018 at 9:55 pm #2477907

    andreaC-50

    Hi Carlos,

    the error "Warning: mysqli_real_escape_string(): Couldn't fetch mysqli in ...." has gone. This is solved.

    But the Translation Editor is not working as expected. I translated again the homepage from Italian to English and the English page is now destroyed.
    You can check logging in the staging copy and compare the Italian Home with the English one.
    Also, if you see in the Translation Editor, only a portion of the sections of the Italian Home page are presented to be translated. The Translation Editor lost a big part of the page (made with Beaver Builder)

    Is the Translation Editor reliable?
    Or there is some dirty data inside the Italian Home page that prevent Translation Editor to work correctly?

    Ciao
    Andrea

    July 9, 2018 at 10:11 pm #2477919

    Carlos Rojas
    Supporter

    Languages: English (English ) Spanish (Español )

    Timezone: Europe/Madrid (GMT+01:00)

    Hi Andrea,

    I suspect this might be:

    1.- A compatibility issue with another plugin or the theme. -> To test this you need to deactivate all plugins and change the theme, if the issue is gone the activate the theme and plugins one by one to find the culprit.

    2.- A corrupted entry in the database, maybe caused by the Memchached -> If the issue doesn't happens in new pages then it could be it.

    3.- For some reason the WPML plugins didn't fetch correctly all the shortcodes of the Beaver Builder -> In this case you need to go to WPML -> Theme and plugins localization -> Scan the plugins related to the builder. It is possible that some shortcodes need to be added manually following the steps provided in this link:https://wpml.org/documentation/support/language-configuration-files/

    Could you tell me the result of the steps above?

    Regards,
    Carlos

    July 9, 2018 at 10:40 pm #2477940

    andreaC-50

    Hi Carlos,
    thanks for your patience.

    We tested solution 1 at the beginning of this thread, and I believe that also after deactivating all the plugins and set "Twenty Seventeen" as Theme, only part of the homepage was included in translation editor.

    Unfortunately, my customer cannot wait longer and I think now the "fastest" solution is to go without the Translation Editor and "creating translation manually" (WPML -> Settings -> How to translate posts and pages -> Translation editor options)

    Now here is midnight and I will continue tomorrow. If the manual translation will work I'll close the ticket.

    But you can keep the duplicator clone and pass it to a WPML developer to understand why Translation Editor fails. I think it could be a good test because this was one of the first website that tried to put together WPML with Beaver Builder and Beaver Theamer.

    Thank you againg
    Ciao
    Andrea

    July 9, 2018 at 10:45 pm #2477948

    Carlos Rojas
    Supporter

    Languages: English (English ) Spanish (Español )

    Timezone: Europe/Madrid (GMT+01:00)

    Hi Andrea,
    Thank you very much for your feedback.

    I will wait for your next messge tomorrow.

    Ciao,
    Carlos

    July 13, 2018 at 4:45 pm #2492532

    andreaC-50

    I decided to start from scratch with a new clone of the production website.

    Until now the procedure I followed to create a staging copy for development was to not touch the production site, leaving all the plugins active, clone the production site into the staging/development site, disable all the caching systems in the staging/develpment instance and then start developing.

    Thanks to Carlos suggestions, I decided to purge the cache and disable all the caching system on the production instance BEFORE clone the website into the staging copy. In this way everything started working ad expected, included the Translation Editor.

    Now the website is fully translated

    Thanks
    Andrea

    July 13, 2018 at 4:46 pm #2492533

    Carlos Rojas
    Supporter

    Languages: English (English ) Spanish (Español )

    Timezone: Europe/Madrid (GMT+01:00)

    Hi Andrea,

    I'm glad to hear that the issue is solved 🙂

    Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
    Best regards,
    Carlos