This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Noman 2 weeks, 5 days ago.

Assigned support staff: Noman.

Author Posts
September 25, 2019 at 1:51 pm #4639443

limE

The error still continues after trying to "Clear" and "Reset". Please help.

September 25, 2019 at 3:24 pm #4640543

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

=== Please backup your database and website ===

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

2. It seems you have just installed WPML plugins and configuring WPML first time on this site and do not have any translated data yet. So you can fix this issue by removing WPML and all its data completely from database.
To do so:
2.1. Please go to WPML >> Support >> Troubleshooting (the link is at the bottom of the support page). >> There, click on “Reset and deactivate WPML” >> then Delete the plugin.

OR

- If you face any issue in accessing WPML >> Support >> Troubleshooting page then please go to *_options database table and delete the ‘icl_sitepress_settings’ entry. This caused WPML to start over with set up.

2.2. After deleting all WPML data and WPML related plugins then please install WPML plugins again and I hope now you will not face any issue.

This issue usually happens due to some corruption in the database, if you are installing WPML first time in this site and you see some database tables starting with <srtong>icl_</srtong> even after reset, please also delete those tables and try reinstalling WPML.

Here is doc for more details:
https://wpml.org/faq/how-wpml-reset-works/

3. If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Thank you

September 26, 2019 at 3:48 am #4643403

limE

I've increased the memory limit, reset and tried with other themes but the problem still persists. Are there any other solutions to this?

September 26, 2019 at 9:12 am #4644885

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site, so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

September 29, 2019 at 4:15 pm #4661091

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for login details. It looks like you're running WordPress with a database user who has no rights to create, drop or modify tables. WPML must be able to create/modify its language tables to run smoothly.

If you're on a shared hosting plan, I suggest to contact the hosting company and ask them to change the database user to a user that can create/drop/modify database tables. This way also required for installing WordPress.

There is some more information about resolving this in the following answer: http://stackoverflow.com/a/8124868

Thank you