This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I get the error notice: WPML is missing some records in the languages tables and it cannot fully work until this issue is fixed. Please go to the Troubleshooting page and click on "Clear language information and repopulate languages" to fix this problem.

Solution: The cause of the issue was that the alert message was stuck in the database. Our 2nd tier specialists removed from the database and the message disappeared.

Relevant Documentation:

This topic contains 11 replies, has 3 voices.

Last updated by Carlos Rojas 2 months, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
March 26, 2019 at 12:39 pm #3462329

kenL-2

I have this test page: hidden link
It has Danish – German language.

Please see attached image. I got that error out of nowhere.

I tried to find the button it says i should click on = there was no button there. Then i was trying to use the "Reset" function in the bottom of the settings page.

But now ALL my pages are merged into DANISH sites, no matter what language they are??

Is there any way we can fix this? or come back?

March 26, 2019 at 7:17 pm #3465867

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I'm sorry to hear that you are having this issue. If you clicked the Reset option then all the language information in the site was reseted too, which means that the fact that you are seeing all the content in Danish is expected.

In this case the best option is to restore a copy of the site made previously to the reset action. In case you don't have a copy of the site, then you will have to manually assign the language information to each posts and pages.

Kind regards,
Carlos

March 28, 2019 at 7:19 am #3477553

kenL-2

Hi again,

Thank you for your reply.

So here i am:

– I have restored my backup of site. Now my 2 x languages is setup correct.

But i still get the error notice: WPML is missing some records in the languages tables and it cannot fully work until this issue is fixed.
Please go to the Troubleshooting page and click on "Clear language information and repopulate languages" to fix this problem.

This warning will disappear once this issue is fixed.

---

But i can't seem to find the button im being guided to? How to remove this, then?

March 28, 2019 at 2:11 pm #3482145

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

I kindly ask you to apply the troubleshooting steps I highlighted in the attached image.

Could you tell me if the issue is solved?

Regards,
Carlos

March 28, 2019 at 7:36 pm #3485199

kenL-2

Hi Carlos,

Thanks for reply.

I clicked on all your marked stuff, but the Error message is still there.
I really don't know what is wrong? hm..

March 29, 2019 at 12:12 am #3486207

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your feedback.

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Looking forward to your answer.
Best regards,
Carlos

March 29, 2019 at 2:29 pm #3492233

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

I double check the site and applied the troubleshooting options but the issue persists. I have escalated this ticket to our 2nd tier of support where our specialists will take a deeper look and will try to find a solution.

I will keep you updated on the evolution of this ticket.

Thank you very much for your patience and understanding!
Regards,
Carlos

March 29, 2019 at 3:42 pm #3492675

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

The cause of the issue was that the alert message was stuck in the database. Our 2nd tier specialists removed from the database and the message disappeared.

Could you confirm that the issue is solved?

Regards,
Carlos

April 11, 2019 at 12:20 pm #3587309

kenL-2

My issue is resolved now. Thank you!

April 11, 2019 at 1:27 pm #3588225

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos

August 7, 2019 at 12:43 am #4350935

carlV-3

Hi there. I am having the same issue. Can you point me to the table that holds this message, please?

August 7, 2019 at 10:19 am #4353579

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi @carlv-3,

The message is stored in the options table.

Regards,
Carlos