Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 4 voices.

Last updated by Anni 4 years, 1 month ago.

Assigned support staff: Shane.

Author Posts
December 9, 2015 at 5:29 am #764264

francoisB

I am trying to: Change the language by clicking on the language flag - example change from French to English by clicking on English.

The problem DOES NOT appear when switching between the home pages in English, German and French.

The problem is for ALL other pages.

URL of (my) website where problem appears: hidden link

I expected to see: When clicking on the French icon I expect to see the French version of the page

Instead, I got: The page remains in English

Before you ask 😉 :

I disabled all other plugins
I tried with a WP theme
I updated the WPML plugins to the latest version

WPML Multilingual CMS Version 3.3.3
WPML Media Version 2.1.17
WPML Sticky Links Version 1.3.16

Thanks in advance

December 9, 2015 at 4:37 pm #764974

Arno

Hello,
I have maybe the same problem...
the footer language selectors does not give the right link to the translations any more...
some routing problem?

December 9, 2015 at 8:01 pm #765202

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Francois,

Thank you for contacting our support forum.

I must apologize for the delay in response.

Could you try changing the permalink settings from the default to the post name ?

To do this you should go to Settings -> Permalinks and then select Postname and hit save.

Once you have done this please try your flags again.

Also could you let me know when this started happening if it's after you updated to WP 4.4

Thanks,
Shane

December 10, 2015 at 3:30 am #765417

francoisB

Hello Shane,

Thank you, it seems to be working this way with the Postname enabled.

For this site the WPML setting is to have languages added as parameters.

For some URL it looks like there is now a double ?lang=fr&lang=fr , like this one :

hidden link

Would that be normal?

In my case, the way the URL reads for this particular site is not important because the site is used so that it can be downloaded on a phone or tablet and used offline at trade shows.

I do have several more sites where I hesitate to update because there I invested time in SEO work for URLs that do not need to change at all.

So I leave the ticket open because even though using Postname is working, reverting back to Plain permalinks brings the problem back.

Thanks again,

December 10, 2015 at 8:13 pm #766351

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Francois,

Did you start experiencing this issue after updating to wordpress 4.4 ?

Please let me know.
Thanks,
Shane

December 11, 2015 at 2:33 am #766513

francoisB

Hello Shane,

Yes I did, after WP 4.4

December 11, 2015 at 6:01 pm #767320

Anni

Hi,
I also have this problem: Click on flag to change language of page does not work. By clicking on flag the same post should be shown in the specific language, but on my site it moves randomly: hidden link This is my live site. It still has the older version of WP 4.3.1. I updated to WP 4.4 on my test site. The problem is with both WP versions. When I made the last WP update on live site everything was working fine. So I thought that this issue has come with the last WPML updates.

December 11, 2015 at 8:46 pm #767415

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hello

We have released a beta update for our WPML plugin.

This beta has fixes that may be able to resolve your issue.

Could you try downloading the beta package and let me know if your issue still remains.
https://wpml.org/account/downloads/

Thanks,
Shane

December 12, 2015 at 4:52 pm #767681

Anni

Hello Shane,

I will try it, if it turns out that WPML is causing the problem. There has been other changes on my site that can cause the problems. The problem with WPML flags is not the only one.

Regards
Anni

December 19, 2015 at 3:47 pm #772988

Anni

Hello Shane,

It seems to me that WPML is not causing the problems on my website:
on staging (test site) the language switch is working correctly. The problem is on the live site. Probably it is a conflict in the hosting environment.

hidden link
hidden link

In the above URL the category part is missing. The URL should be: hidden link
Either way, Google finds the article, also without the category part in the slug.

But maybe that is the reason why WPML doesn't connect the articles correctly, but moves randomly between articles and archives. I was unable to change the style of permalinks. It is set to 'Post name' now. What do you think?

Regards
Anni

December 22, 2015 at 8:56 am #774459

Anni

Hello Shane,
The new update of WPML resolved the problems on my site. Thank you 🙂
Merry Christmas!
Sirkka