This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by Yvette 1 month, 2 weeks ago.

Assigned support staff: Yvette.

Author Posts
August 13, 2019 at 4:16 am #4384983

danielS-180

I am trying to: press the Spanish button and go from English to Spanish version of site.

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link

Instead, I got: hidden link

*I've recently updated my temp url to the actual domain cochamo.com.

August 13, 2019 at 11:50 am #4387539

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

On the home page, the language switcher will look up the values "site_url" and "home" from the database.

Please check these settings in your panel: Settings > General

Is this value appearing in either "WordPress Address (URL)" or "Site Address (URL) "?

Thanks

August 13, 2019 at 3:51 pm #4389333

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Hmm - interesting.

1. Technical Information on you environment
Could you please provide information about your environment by following thsese steps: http://wpml.org/faq/provide-debug-information-faster-support/

2. If this is a multisite network - please provide wp-admin privileges for the network.

3. Can you please check the wp-options for other sites on the network? Do any of them have the site_url or home set to the value "cochamoc.wwwaz1-ls12.a2hosted.com/site-1/"

4. Diagnostic
If you temporarily deactivate all non-WPML plugins and temporarily change your active theme to Twenty Nineteen - does the language switcher also have the same issues on the home page?

August 14, 2019 at 12:37 am #4391169

danielS-180

Hi Yvette,

Thanks for your continuous help. According to your numbered steps:

1. I followed the steps to get the debug information but it is blank.

2. Do you mean provide you a login and password? Yes, it is a multisite network. I recently changed from the temp url to my domain url.

3. No. The table wp_options urls are set at hidden link

4. I can no longer access My Sites > Network Admin. My cochamo.com/wp-admin/ works fine but if I select My Sites > Network Admin, it takes me to the address hidden link, which gives me a 404 Not Found page. Now, I imagine you'll be tempted to tell me to contact you're hosting provider, but your help has been awesome and I'd love to try any suggestion you may have. Furthermore the wp-config.php file has also been updated to cochamo.com:

/* Multisite (Old domain_current_site = cochamoc.wwwaz1-ls12.a2hosted.com) */
define( 'WP_ALLOW_MULTISITE', true );

define('MULTISITE', true);
define('SUBDOMAIN_INSTALL', false);
define('DOMAIN_CURRENT_SITE', 'cochamo.com');
define('PATH_CURRENT_SITE', '/');
define('SITE_ID_CURRENT_SITE', 1);
define('BLOG_ID_CURRENT_SITE', 1);

Okay, awaiting your help.

Saludos,

Daniel

August 14, 2019 at 9:25 am #4393707

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

1. wp-congir.
Hmmm - so with a "minimal setup" (only WPML Plugins activated and using a standard wordpress theme) the result is that you are redirected to:

hidden link

You wrote: "Furthermore the wp-config.php file has also been updated to cochamo.com.."

With this change, are you *still* being redirected to the cochamoc.wwwaz1-ls12.a2hosted.com URL?

2. Other suggestions
The only other suggestion I have for you is to also check the .htacess file for anything out of the ordinary.

However, I do think you would get faster/better support in that area by contacting your hosting provider = )

August 16, 2019 at 3:23 pm #4407263

danielS-180

Hola Yvette,

I was able to get some more function via the multisite issues.
- However the debug info is still blank.
- The wpml language switcher is taking me to hidden link", when it should go to "hidden link"

Ok awaiting your reply.

Saludos,

Daniel

August 19, 2019 at 10:17 am #4415127

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I´m a bit confused.

The information you posted - is this the result of editing the wp-config.php file as you described in your message - point 4: https://wpml.org/forums/topic/clicking-on-the-language-button-to-switch-languages-goes-to-the-incorrect-url/#post-4391169

The language switcher will create the "language specific URL" using only the entries it finds in site_url and home

If you check the database entries now for these values - do you see anything that matches what you see in the permalink base? sepcifically "hidden link"

--OR--
Is there anything in the .htaccess that would create this rewrite of the permalink base?

--OR--
checking with your server support, is there anything that they might be doign to create this new string?

The bottom line is that if site_url and home are both showing the expected "hidden link" for your particular site but the permalink base is adding "*", there is some server-related step that is adding this rewrite.

August 21, 2019 at 2:54 pm #4432445

danielS-180

Hi Yvette,

Sorry to confuse you. I'm doing my best. To answer your questions:

- In wp_options table of the database, the siteurl and home are set to "hidden link". If there are more places within the database, I am unaware of where or how to find them.

- .htaccess file: Maybe there is something creating a rewrite. It's beyond my knowledge. Can I include a copy for the next reply?

Sorry for the delay answering. I was preoccupied. I will be more frequently connected.

Awaiting your reply.

Daniel

August 22, 2019 at 1:33 pm #4439757

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I tried to connect again to your site, but the username/password provided previously no longer works.

Could you check this please?

August 22, 2019 at 6:28 pm #4442209

danielS-180

I just tested your login and password in an incognito window and it worked. Please use the password from the private message, NOT the last message.

Awaiting your reply.

August 23, 2019 at 1:56 pm #4447907

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

It seems strange to me that you have 2 sites with the same domain name: cochamo.com (see image).

From what I can deduce, the language switcher is doing exactly what it supposed to be doing. When you visit your site id=2 (ie. site-1) it is being mapped to cochamo.com. However, as I stated before, the languag switcher for the home page will use the siteURL value and append a language code to it.

The site URL is cochamo.com/site-1/ ( see image).

This gets confusing because then the system will go to the wordpress files belonging to siteURL cochamo.com....which is not what you want.

I would consider eliminating the cochamo.com (site id=1) to remove this confusion but perhaps you need to ask your server support for help on this matter.

August 29, 2019 at 7:14 pm #4483167
danielS-180

Hola Yvette, after lots of time, I just started over. Reinstalled wp, plugins, posts, etc and updated the rest manually. Now, I'm back to hopefully a basic question: I can't get a language switcher button on my upper menu "top-menu - English" for cochamo.com. Have tried everything I did before, but must be missing something. I've set your login n pw to the same as before.

New threads created by Yvette and linked to this one are listed below:

https://wpml.org/forums/topic/split-i-cant-get-a-language-switcher-button-on-my-upper-menu/

August 30, 2019 at 6:50 am #4484963

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

You wrote: ":..after lots of time, I just started over. .."

= ) Sometimes this can be the best option.

Since we are starting a new topic, I´ve set this particular thread to "closed" and split out a new one wehre we will continue our work.

August 30, 2019 at 12:04 pm #4486981

danielS-180

Hola Yvette, I dont know if it was you or I simply didnt clear my browser. but all good. The language switcher appears and is in the correct place. Thanks for your great help. I know my issue was un quilombo. Saludos, Daniel

August 30, 2019 at 4:57 pm #4488443

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

OK - marking this ticket as resolved.