This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Code section doesn't work in any translated languages

Solution: Translating the code section to the secondary languages solved the issue.

This topic contains 5 replies, has 2 voices.

Last updated by kevinM-29 3 months, 3 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
June 21, 2019 at 5:11 pm #4068653

kevinM-29

I am trying to: The homepage of the referred website doesn't work when switching to the translated languages. (French and Portuguese)

Link to a page where the issue can be seen: realestate.atomivox.net

I expected to see: English version, below the "search section", there's a code that pulls and displays all listings.

Instead, I got: Both in Portuguese and French, it retrieves a "Nothing to display" message where the listings (translated versions) should appear.

June 24, 2019 at 5:52 am #4074777

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

Have you translated the listings in all languages?

Could you please go to WPML->Languages->Language filtering for AJAX operations and enable "Store a language cookie to support language filtering for AJAX" and let me know if this helps?

Look forward to your reply.

Thanks

June 24, 2019 at 9:43 am #4076103

kevinM-29

Good morning, Shekhar

We tried to enable the "Store a language cookie to support language filtering for AJAX" option but unfortunately it didn't fix the issue.
There's still a code section in the website that oddly, it's not being picked up on the translated options. On the same page, there is another code section that works perfectly though. Let me know if you have any other possible solution for the problem, or if you might need to have direct access to the website to perform some additional troubleshooting.

Thank you

June 24, 2019 at 9:46 am #4076113

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Sure, provide me the login details so I can quickly check the issue, to debug this issue further, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

June 24, 2019 at 10:40 am #4076565

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Since the listing is not being translated, it is not being shown on the secondary language pages, please translate the listings to solve the issue.

I added a translation and it's working perfectly here: hidden link

Let me know if this helps.

Thanks

June 24, 2019 at 12:33 pm #4077279

kevinM-29

My issue is resolved now. Thank you!