This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I used a Variation Swatches for WooCommerce plugin, after set all colors I see that in english I have the translation but not the color Solution:

  • set the attribute_pa_colors custom field to Copy in WPML -> Settings -> Custom Fields Translation;
  • go to WooCommerce -> WooCommerce Multilingual -> Attributes tab;
  • select the Colors attribute;
  • for each existing color, just press the pencil button and hit the Save button.

This topic contains 9 replies, has 2 voices.

Last updated by davideG-16 3 months, 1 week ago.

Assigned support staff: Radu.

Author Posts
July 10, 2019 at 10:32 am #4178713

davideG-16

I used a Variation Swatches for WooCommerce, after set all colors I see that in english I have the translation but not the color... I saw your thread (https://wpml.org/forums/topic/woocommerce-variation-swatches-missing-images-on-translations/)and I did this...
1) Visit WPML>>Translation Management>>Multlingual Content Setup page
2) Scroll down to *Custom Term Meta Translation* section
3) Then choose *Copy* as translation preference for image, order, and thumbnail_id fields
4) Save the changes
5) Visit WPML>>Support>>Troubleshooting page, click on *Clear the cache in WPML* button

But in english version I have not the colors...
Do you have any idea?

July 10, 2019 at 12:08 pm #4179957

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Davide,

Thank you for reaching out the WPML support!

As I can see, this WooCommerce Variation Swatches plugin is not a part of our WPML compatible plugins (https://wpml.org/documentation/plugins-compatibility/). However, we can try to check this out and see if there's anything we can do to make them work together.
Firstly, can you deactivate all the plugins except for WPML (and its add-ons) and Variation Swatches, activate a default theme (like Twenty Nineteen), and tell me if this issue is still available, please? This little test will show us if this issue isn't caused by a compatibility between some other plugins that you're using and WPML or Variation Swatches. Please let me know how this goes.

Thanks,
Radu

July 10, 2019 at 2:40 pm #4181545

davideG-16

I'm sorry it's not compatible. In any case, the problem is not that it doesn't work.
If I create a new color (after modification the pa_colour *Copy*... it brings me the image/color in the second language.
Since I have already created 32 colors I ask you if it's possible to delete the wpml cache so that it takes my colors. The clear cache doesn't work. How can i reconnect the translations/colors? There is any tip? BR

July 11, 2019 at 10:07 am #4188431

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Davide,

Please give me access to the dashboard area and I'll have a look to see if there's anything we can do to make the existing colors be copied too. The next reply is private so you can safely send me the credentials.

Thanks,
Radu

July 12, 2019 at 7:53 am #4196067

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Davide,

Thank you for sending me the credentials. Now, can you tell me what's the new color that you added (the one that's working), please? Also, can you attach a link to a product where the colors are not copied to the translation? Everything should be fine once you set pa_colour to copy. This is why a link to a product where this is not happening would be helpful (so I can check things out).

Thanks,
Radu

July 12, 2019 at 11:11 am #4197981

davideG-16

Hi Radu, the last color was PLUM.
Here the link where the color are not copied: hidden link

BR

July 15, 2019 at 9:29 am #4209145

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

I checked this part of the products. It seems that the translation of the colors doesn't have the color set. For example, I edited this color in English hidden link, selected the color on the Color field, and saved the changes. Once I did that, the color on the English version of this product hidden link was back to normal. Can you check all the other colors and make sure that the color is set on the English translation, please?

Thanks,
Radu

July 15, 2019 at 9:40 am #4209289

davideG-16

Maybe I can't explain myself. I know that if I set the color in English I see it. But my question is different, and after 5 days I have no answer.
The colors works, and we know that. Since I have already created 32 colors I ask you if it's possible to delete the wpml cache so that it takes my colors....??!! wrote on 10Th July... However, I should close the ticket and do it by hand. Best Regards.

July 15, 2019 at 12:59 pm #4211293

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Davide,

Once you set the attribute_pa_colors custom field to Copy (in WPML -> Settings -> Custom Fields Translation), you can go here hidden link, select the Colors attribute, and for each color, just press the pencil and hit the Save button.
I did this for a few colors and it works very well. This is the most simple solution I found in order to make the existing colors be copied. Can you give this a try and tell me how it works, please?

Thanks,
Radu

July 15, 2019 at 1:17 pm #4211353

davideG-16

My issue is resolved now. Thank you!