This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: It looks like the translation module is ignoring some style settings. I tried this first just adding translation. Then cloning the element. Then recreating the element.

Solution: I had to edit the default language to force an update to finish the translation. After saving 100%, it was working.

The problem is that when you edit an existing translation, the layout information is "frozen". In this case, you need to update first the default language that this update will be pushed to the translated version.

Relevant Documentation: https://wpml.org/documentation/plugins-compatibility/how-to-build-multilingual-sites-with-wpbakery-page-builder-and-wpml/

Tagged: 

This topic contains 4 replies, has 2 voices.

Last updated by jariH-3 2 months, 1 week ago.

Assigned support staff: Marcel.

Author Posts
August 7, 2019 at 9:52 am

jariH-3

I am trying to: Setup WPML to translate our old (www.navigil.com) site to several languages.

I've created a duplicate (duplicated EC2 image in AWS) of our site to test WPML

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link

It looks like the translation module is ignoring some of the style settings. I tried this first just adding translation. Then cloning the element. Then recreating the element. Background was not visible. Then I created a brand new test page and did a some testing there. It looks like the background works in section but not inside a row column.

It looks like this column setting is missing totally from translated content:

.vc_custom_1559291896583 {
padding-top: 75px !important;

padding-bottom: 75px !important;

background: #f2f2f2 url(hidden link) !important;

background-position: center !important;

background-repeat: no-repeat !important;

background-size: cover !important;
}

The attached image is from the editor in the test page. The first element works, but the second does not. First is just a section with image and the second is a row element with two columns.

OK hidden link
FAIL hidden link

I hope you can help with this. Otherwise the plugin seems to work great and it is easy to translate the content. Without showing the background we can't use the plugin since the whole sait is laid out using these features.

August 7, 2019 at 2:19 pm #4355917

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Jari,

Thank you for contacting WPML Support.

Now it's working: hidden link

I had to edit the default language to force an update on the Finish translation. After saving 100%, it was working.

The problem is that when you edit an existing translation, the layout information is "frozen". In this case, you need to update first the default language that this update will be pushed to the translated version.

Best Marcel

August 8, 2019 at 8:53 am #4361177

jariH-3

Hi,

Thank you for looking into this. I can see that your example now works. I tried to add a new element and do the translation but I'm getting the same result.

What I did was that I:
1. created a new element
2. updated the details
3. published
4. translated all content to 100%
5. returned to page
6. published
7. updated original content
8. translated again
9. published

ENG works, but FIN does not.

I was able to get this working by turning off "Use WPML's Translation Editor" temporarily. Then I updated the page and everything worked just fine. I think I can manage with this.

BR,

-jari

August 8, 2019 at 1:11 pm #4363159

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Jari,

Great, otherwise please tell me which page is affected and I can take a look if you are stuck.
 
Best Marcel

August 8, 2019 at 1:13 pm #4363175

jariH-3

My issue is resolved now. Thank you!