Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:
Yoast SEO Multilingual causing server error with LearnPress
Solution:
This will be fixed by LearnPress developers in upcoming versions

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by petkoA 1 year, 4 months ago.

Assigned support staff: Bruno Kos.

Author Posts
March 12, 2021 at 10:06 am #8292219

petkoA

Hello,

We're experiencing issues with the compatibility between Yoast SEO Multilingual and Yoast SEO Premium. The issue persists after Yoast SEO Multilingual version 1.1.1 (this is the last version that works fine).

The issue can be seen on these LearnPress "course_category" custom taxonomy pages (these are the LearnPress course categories):
hidden link
hidden link
hidden link
hidden link

The issue persists with both the free and the premium versions of Yoast SEO.

I have created a user to test this, but cannot provide credentials here, because I don't see the field for private information.

March 14, 2021 at 11:07 am #8304865

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

On this sandbox (I added all the required plugins I believe, install if anything else is needed):
hidden link

can you reproduce the issue with at least 1-2 LearnPress course categories? Make sure to configure WPML to have the same languages.

If you manage to reproduce the problem, let me know what the issue is exactly as I don't see it from your problem description.

Regards,
Bruno Kos

March 14, 2021 at 10:31 pm #8306273

petkoA

Hello,
I have replicated the issue here: hidden link
And here: hidden link

March 15, 2021 at 9:44 am #8309101

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I see, it hits server error 500 when Yoast SEO Multilingual is activated. I guess this is what you are reporting?

This has been escalated to our Compatibility team and may take some debugging time, I'll get back to you as soon as I have any news or questions for you.

Regards,
Bruno Kos

March 16, 2021 at 11:50 am #8320347

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you try adding the code from previous private reply to your theme functions.php?

Does it work?

Regards,
Bruno Kos

March 17, 2021 at 7:37 am #8328463

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

From the Learnpress author:

*****
We know will have the error category of LearnPress when activating the Yoast SEO plugin and we will have a new update for LearnPress to fix it soon, maybe this week.
*****

Regards,
Bruno Kos

March 17, 2021 at 8:32 am #8328785

petkoA

My issue is resolved now. Thank you!