This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 33 replies, has 2 voices.

Last updated by Jochen 5 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
April 10, 2019 at 6:14 am

Jochen

Tell us what you are trying to do?
I am using Cloudflare. If cloudflare is in development mode (bypassed) all fine. As soon as I switch it on I get this message from WPML:

"It looks like languages per directories will not function. Details

This can be a result of either:

WordPress is installed in a directory (not root) and you're using default links.
URL rewriting is not enabled in your web server.
The web server cannot write to the .htaccess file"

my side is: hidden link

April 10, 2019 at 8:03 am
April 10, 2019 at 1:40 pm #3576779

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I have checked the flow. It seems the Tags is set to Administrative visibility and the user has no access to create a tag. The issue may be during the tag selection in the backend or might be a caching issue.

Please follow the steps.

1) Clear your site cache
2) Goto WPML > Support > Troubleshooting under clean up section click on Clear WPML cache
3) Goto WPML > Settings > How to translate post under taxonomies Enable " Don't include already translated terms in the translation editor" this will make sure the translation fetched from the existing tag translation

Once done update the post and its translation which has the issue and try submitting a new request from hidden link check whether you can reproduce the issue.

Let me know the results

Kind regards
Raja

April 11, 2019 at 6:50 am #3584203

Jochen

Hi Raja,
I followed the steps you recommended but the issue still persists:
hidden link

Regards
Jochen

April 11, 2019 at 9:32 am #3585697

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for trying the steps.

I can see the issue is happening only to the first post or the latest post.

Please try one more debugging step.

Backup your site and database

Temporarily Change the theme to any of WordPress default theme and check the URL hidden link does it still show the first post with tag bag?.

If the issue persists. try the below steps

- Increasing the memory limit to 256 MB add the below code to wp-config.php file if the code already exists increase the value

 /** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Increase PHP max input vars to 3000 you can follow the link below to try it yourself, or send a request your hosting provider
hidden link

let me know the results.

kind regards
Raja

April 12, 2019 at 10:30 am #3597655

Jochen

Hi Raja,
the issue is only with the last post as the other posts are either not generated with the automated flow (I am implementing it now) or I manually corrected. Therefore I assume it has nothing to do with the memory limit. Or do you want me still to try out the steps you propose?
To me it looks like that for a reason I dont get, during the page generation the tag gets assigned correct but not the tag label. So that the filter to display the right posts works fine in both language but the displayed tag in German is wrong.

April 12, 2019 at 12:58 pm #3599117

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jochen,

Memory and Php vars may be interrupting the flow, it is better to try the steps I have sent you before and see if it helps. Most of the frontend rendering issues will be solved once we increase the memory and PHP max input vars. I would highly recommend you to kindly try those.

If that did not help much we might have to debug this issue further.

Kind regards
Raja

April 12, 2019 at 7:06 pm #3601375

Jochen

Hello Raja, I followed your advice but the issue still percist. While checking the issue I persived something which is might related to the rootcause:
The WPML setting: "Post Types Translation" was set to "Translatable - use translation if available or fallback to default language". With this setting when I am on hidden link the post hidden link was incorporated in the post list (means german text but english tag). Once I switch to the setting; "Translatable - only show translated items" the german bag post is no longer incorporated in the list. Any idea?

April 15, 2019 at 5:26 am #3609775

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thanks for the investigation.

I have Purged the opcache from WP Rocket I am now able to see the first post in the list hidden link

Seems like the earlier issue is also related to opcache from WP Rocket.

I still suspect the rending of the page has some issue with WPML. as I can see the bag tag along with the translated version tasche.

Please change the theme to WordPress default theme and check whether you still see the same issue Kindly grad a screenshot of the page hidden link after changing to WordPress default theme.

Please perform the above action after securing a backup of your site and database

Kind regards
Raja

April 18, 2019 at 12:10 pm #3639019

Jochen

Hello Raja,
I can do this check but would wonder if the Theme is the issue as I am using the same Theme on my testpage where the issue is not there: hidden link

April 18, 2019 at 12:10 pm #3639021

Jochen

will do this test tomorrow morning

April 19, 2019 at 5:53 am #3643671

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks, Please also perform a test disabling WP Rocket plugin.

Kind regards
Raja

April 19, 2019 at 10:52 am #3645079

Jochen

Hello Raja,
I tested now with the twenty nineteen theme and WP Rocket plugin deactivated and Cloudflare switched off. The issue is still the same. The DE post get generated and has two tags the english and the german version of the tag. The EN post has the english tag only.
Any idea?
Regards
Jochen

April 19, 2019 at 11:19 am #3645291

Jochen

one more comment: try to identify differences on my testing page and the life page. One thing is, that historically I have not only tags added in English and translated via the WPML taxonomy translation tool but also German tags transated to english. I wonder if this might have an impact?

April 19, 2019 at 1:35 pm #3646117

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for detailed testing, I'm not sure what could be the reason here, I might need to clone your site to our private server let me if that is okay for you, I will send the details in my next private reply.

I have checked the tags and its translation i don't see any big noticeable issue there.

Kind regards
Raja