Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 35 replies, has 3 voices.

Last updated by Ankit 4 years, 6 months ago.

Assigned support staff: David.

Author Posts
January 31, 2017 at 5:27 pm #1195206

Kristof

I have been looking for a solution where with both W3TC and WPML enabled, all minified files were not removed from the source code. You had the minified css file at the top and still the for example Avada styles remained in the head.
I first thought either Avada or W3TC were to blame, until I just disabled all plugins in the test site and enabled them one by one. Only when WPML was enabled did the issue occur. The other way round also, with all plugins enabled, the problem disappeared when I disabled WPML.

On the test site hidden link we have minified wp-content/plugins/revslider/public/assets/css/settings.css and wp-content/themes/Avada/assets/css/style.min.css, but with WPML enabled, they are still in the html code, with WPML disabled, they are gone, like it should.

PS: notice also the extra empty space before <html> with your plugin enabled.

Screenshot_2.png
Screenshot_1.png
February 1, 2017 at 12:20 pm #1196060

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I'm trying to confirm your problem on my local install.

Meanwhile would you like to share access details so I can double check your W3TC configuration?

I have marked your next reply as private.

February 1, 2017 at 1:41 pm #1196193

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I tried minifying with w3-total-cache on my local setup and it worked fine.

Then I started checking your staging site, but w3-total-cache is not even active.

Is this an old duplicate or something?

February 1, 2017 at 2:37 pm #1196293

Kristof

Hi David Garcia,
My bad, I was experimenting on this same staging with the WP Rocket plugin, so I had to disable the W3TC plugin first. The issue is not that files are not being minified, they are, but their original versions remain in the html source code with WPML enabled.
When you disable WPML, minification still works, but the original .css files are gone, which is what my screenshots showed.

February 1, 2017 at 6:48 pm #1196611

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I updated WPML + addons to the latest versions and it seems to be working correctly now.
Can you double check?
Let me know how it goes.

February 1, 2017 at 8:12 pm #1196686

Kristof

Hi,
Indeed, on our test site, the original files have been removed from the html source after minification. We have now updated all WPML plugins on our main site hidden link but there the issue is still visible 🙁

I have briefly disabled the WPML Multilingual CMS plugin there and then the original versions of the minified files were removed, when I enabled WPML again, the duplicate files were visible.

I can give you access to the live site as well.

February 2, 2017 at 12:22 pm #1197390

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Yes, ok. Lets take a look at the live site.
I'll be careful to not break anything but make sure you have a backup anyway.
I have marked your next reply as private.

February 2, 2017 at 4:08 pm #1197723

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Is there any problem if I update gravityforms-multilingual too?

February 2, 2017 at 5:04 pm #1197802

Kristof

Hi,
I have updated the plugin for you, however it still says "WPML Update is Incomplete"

February 3, 2017 at 11:42 am #1198676

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

De-activating WPML and activating again resolved the update issue.

Let me check your original issue with W3TC now.

I will get back to you shortly.

February 3, 2017 at 1:35 pm #1198809

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Im going to make a duplicator package to debug this problem local.
Everything seems correct on your site but its still not working.

February 3, 2017 at 4:17 pm #1199017

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

In my local setup its working as it should.

Can you make a fresh duplicate on your staging site?
I dont want to do testing on your live site.

February 3, 2017 at 5:18 pm #1199086

Kristof

Hi, first of all, I am now seeing this message in the live site, what does this mean?
"Warning: You are trying to edit a translation using the standard WordPress editor but your site is configured to use the WPML Translation Editor."

Second, I have created a fresh duplicate on the staging site.
hidden link

February 6, 2017 at 1:25 pm #1200366

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I'm sorry, I did enable the Translation Editor and didn't put it back.

I have reverted this setting now.

I'm taking a look at the staging site now.

Thanks

February 6, 2017 at 5:43 pm #1200813

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

It seems to be a problem with the "Use directory for default language" setting.
I disabled it on your staging site and it worked as expected:

The problem is that I wasn't able to reproduce this on a fresh install, even with directory-for-default-language turned on.

Im going to try several combinations until I find the culprit and I will get back to you.

The topic ‘[Closed] Compatibility issue: W3TC minified files are not removed from source code’ is closed to new replies.