This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by jorgeA-19 1 month ago.

Assigned support staff: Marcel.

Author Posts
September 12, 2019 at 10:37 am

jorgeA-19

using the page below as an example as this same issue happens with other pages:

hidden link

the translation for the page has been completed for Portuguese-Brazil and French, it is in progress for Spanish and Portuguese-Portugal.
Anyone accessing the page will see that only the French translation is available (check the language switcher at the footer), the other translations are not available, however if I access the page (as a registered user/admin) I can see them all.

could you please advise?

We are using WordPress 5.2.3 and WPML 4.2.8
The page was created with Elementor (by the way I cannot enable the translate on elementor, it basically doesn't do anything when I click on "enable it now") and, if this helps, it was cloned from a previous page which has also translations

September 13, 2019 at 8:41 am #4566621

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Jorge,

Thank you for contacting WPML Support.

I see no translations are hidden on your Backend. Could you please try to finish the open translations to 100% (All on pencil icon).

Please let me know.
Best Marcel

September 13, 2019 at 8:53 am #4566697

jorgeA-19

Hi Marcel

As you can see on the attached screenshot the translation has been completed for Portuguese but it is not showing up on the page

September 13, 2019 at 8:59 am #4566745

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Jorge,

if you re save the page it's working.
Please check hidden link over Incognito mode.

September 13, 2019 at 10:46 am #4567629

jorgeA-19

I can see it's fixed now, can you let me know what do I have to do next time this happen please?

September 13, 2019 at 10:58 am #4567715

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Sure,

I only opened the Portuguese page and pressed "Update". That's all 🙂

Best Marcel

September 13, 2019 at 11:03 am #4567825

jorgeA-19

My issue is resolved now. Thank you!