This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 3 voices.

Last updated by siaE 1 year ago.

Assigned support staff: Ahmed Ibrahim.

Author Posts
September 19, 2018 at 7:22 am #2747552

siaE

Hello,

we have implemented a connection from WordPress to SDL TMS through Language Cloud. It works well, we can intiate translation requests from WordPress, files are send back and forth from/to our TMS.

Now in TMS, after translated files are retrieved by WPML, translation jobs are not pushed to completion. I touched base with SDL tech support and they believe something is missing in the WPML connector setup. Apparently some industry-standard commands have to be sent to TMS to that jobs are pushed to connection. Here is what SDL tech support described:

'L10NCOMPLETEREQUEST' and 'L10NCOMPLETERTESPONSE' are industry standard names used by most connectors; details about each shown below.

-'L10NCOMPLETEREQUEST' is sent from your system to TMS after acknowledging it has successfully received translated file(s)

-'L10NCOMPLETERTESPONSE' is what TMS send back in response to the receiving the 'L10NCOMPLETEREQUEST' and then the Task status is changed from TCR to Complete

Can you please check if something is missing in our setup?

Thanks in advance,

September 19, 2018 at 10:06 am #2748230

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi, and thanks for contacting our support forum.

So if I understand you correctly, you have sent some documents to SDL TMS, and these documents have been translated completely and WPML received the translations correctly, but you are missing a confirmation message from WPML to tell SDL that the documents have been received, right?

Please let me know so I can have a full picture and check the issue with our TP dev team.
Best Regards.

September 19, 2018 at 11:28 am #2748564

siaE

Hello Ahmed,

you captured it just right.

The translated files are still in SDL TMS in a stage called "Translated Content Retrieval". This is the stage when a call from a connector can be made to retrieve translated files, and push them to completion in TMS.

SDL Tech support believe that something is missing for the files to be sent to completion: some sort of confirmation message coming from WMPL to instruct TMS to move the files forward in the workflow, i.e send them to completion.

Thank you for your assistance,

September 19, 2018 at 11:46 am #2748610

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for your reply, I have escalated the suggestion to our developers and will update you soon I get their reply.

Best Regards.

September 20, 2018 at 8:52 am #2751519

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Our developers said that WPML should send these notifications for you, so they need to check your batch to see if there is anything wrong with it, so can you please go to WPML -> Translation Management -> Translation Jobs, and let me know what is the batch name and the batch ID for the batches that have the issue. (you can find the batch ID in the URL if you clicked on the batch name)

Best Regards.

September 20, 2018 at 1:39 pm #2752351

siaE

Hello Ahmed,

we processed two batches, with the same result:

- Test35|en|8 (job ID 19302)
- FAQTEST_32|WPML|8 (job ID 19207)

Thank you,

September 20, 2018 at 10:42 pm #2753377

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Thanks, I have sent them to the dev team, and will update you soon I get their reply.

September 21, 2018 at 10:47 pm #2756610

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Just to let you know that our developers are working with SDL team to make it work, and I will update with the news.

Best Regards.

September 27, 2018 at 12:56 pm #2770536

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Just to let you know that this issue has been fixed.

Thanks

October 4, 2018 at 4:04 pm #2788128

siaE

hello again,
Unfortunately, we are unable to send any translation jobs. Is there anything in this recent fix that could affect the ability to send jobs to TMS? We get this message but no success pop-up and none of the test jobs we have sent since Monday 10/1 have reached SDL TMS. There is also no record of the sent jobs in Jobs tab. We have tried from various locations and both our staging & production servers. We only get the 'done' messaging. Thanks again for your help,

October 8, 2018 at 2:27 pm #2796431

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi, and thanks for testing this.

The last update shouldn't make any problems with sending the posts to the service, so please send me the site credentials, and I will test it my self to see what is going wrong, also please send me the title of the page that you want to send. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

+ Please make sure that you have a full backup of your website and database.

Best Regards.