Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by Itamar 1 month, 2 weeks ago.

Assigned support staff: Itamar.

Author Posts
September 19, 2019 at 3:31 pm #4606901

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Thanks for this extra information.

When our compatibility will check this issue they will determine whether the _bto_data field needs to be set to 'Copy' or 'Don't translate'.

October 2, 2019 at 11:25 am #4679665

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

Our compatibility team has found the source of this issue, and we are sharing with you a temporary fix for the issue.

1. Open this file with the code editor program that you are using.
/wp-content/plugins/woocommerce-multilingual/compatibility/class-wcml-composite-products.php

2. Go to line 105 and change this line:

if ( empty($product_translation->original) ) {

With this line:

if ( !empty($product_translations[$product_translation->language_code]->original) ) {

3. Save the change.

Now the problem should not occur again. Please let me know if it is working for you.

The issue is escalated to our developers and will be included in future versions of WooCommerce Multilingual. If you update the WooCommerce Multilingual plugin before the fix is included, please remember to insert the fix again.

I'll keep you updated here when the version with the fix is released.

Regards,
Itamar.