Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: I've used your Gravity Forms Multilingual plugin to translate this Gravity Form:

The problem is that the conditional fields aren't added to the submission or to the admin notification email, even when they're filled (tested this more than once)

Solution: Conditional fields have labels and values. When translating a form using the Classic or Advanced Translation Editor, to display conditional fields on any of the secondary language forms, you need to translate the labels only and set the value as not translated.

Relevant Documentation: - https://wpml.org/documentation/related-projects/gravity-forms-multilingual/#translating-gravity-forms-conditional-fields

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

No supporters are available to work today on this forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

This topic contains 2 replies, has 2 voices.

Last updated by sanneI 2 months, 3 weeks ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
February 17, 2021 at 11:37 am #8106233

sanneI

Hi there,

I've used your Gravity Forms Multilingual plugin to translate this Gravity Form: hidden link

The problem is that the conditional fields aren't added to the submission or to the admin notification email, even when they're filled (tested this more than once)

It does work for the original form (Dutch), but not for the translations.

Can this be fixed?

Kind regards,

Sanne

February 19, 2021 at 7:43 am #8124667

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello Sanne,

thanks for sharing info about your issue.

Can you please follow the next steps and let me know how it goes:

Please make a backup before proceeding.

1) Please open and add the following code in your wp-config.php file, right after the database information lines of code. This file is located in your websites root folder.

 /** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

2) Can you please check if the issue happens when only WPML plugins and Gravity forms activated, all other plugins disabled? Please change your theme to the WP default theme and check if the issue happens.

3) Please make sure you have not translated conditional field value, as instructed in our docuemantion. I suggest you create a new test form following our documentation and see if the issue happens.

Conditional fields have labels and values. When translating a form using the Classic or Advanced Translation Editor, you translate the labels and values. To display conditional fields on any of the secondary language forms, you need to translate the labels only and set the value as not translated .

Info: https://wpml.org/documentation/related-projects/gravity-forms-multilingual/#translating-gravity-forms-conditional-fields

Please let me know how it goes and don't hesitate to ask if you find any problem along the way or have doubts or questions about the steps mentioned above, I'll do my best to help you in the best way possible.

Regards,
Drazen

February 22, 2021 at 7:59 am #8141957

sanneI

My issue is resolved now. Thank you!