This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: How to translate conditional fields on a Gravity Form?

Solution: Conditional fields have Label and Value, so if you want to show the conditional fields on both translation languages you need to translate label only and set the value as not translated. If you translate the value, the conditional fields don't work. So, go to Strings Translation and uncheck "Translation is complete " checkbox for the conditional fields values if translated.

Relevant Documentation: Please reference this ticket: https://wpml.org/forums/topic/repairing-conditional-logic-on-translation/

This topic contains 8 replies, has 3 voices.

Last updated by pidjouc 2 years, 3 months ago.

Assigned support staff: Lauren.

Author Posts
June 21, 2017 at 2:01 pm #1302844

simonB-6

I have a field (with label "please specify") with Conditional logic. This field should only appear if the user click "Yes" when asked Do you require any special assistance?. This working perfectly with the English version, but not working with my translated version.

URL of (my) website where problem appears: hidden link
Authentication User: demo
Authentication Pass: Lana5236

June 21, 2017 at 5:56 pm #1303047

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Usually, conditional fields have Label and Value, so if you want to show the conditional fields on both translation languages you need to translate label only and set the value as not translated. If you translate the value, the conditional fields don't work. So, go to Strings Translation and uncheck "Translation is complete " checkbox for the conditional fields values if translated. Please reference this ticket: https://wpml.org/forums/topic/repairing-conditional-logic-on-translation/

Please let me know this resolves the issue.

June 22, 2017 at 8:10 am #1303353

simonB-6

Hi,

I am trying to find the value of my field but it doesn't have one. There is only label.

Regards,
Rachelle Agius

June 22, 2017 at 7:29 pm #1303950

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

June 23, 2017 at 2:34 pm #1304582

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending credentials. I was able to find the value strings. I changed the text domain drop down at the top to gravity_form_1 and then searched for "Yes". You can see in my attached screenshot the results. I believe the field ID is 24, so those are the ones you will want to set to not translated.

Please let me know if you need any further assistance and I will be happy to help.

June 26, 2017 at 8:22 am #1305353

simonB-6

Hi,

I did as you said in your comment, and I still cannot make it work.

Attached please find what I did in the translation (screenshot1.PNG) and the result that I am getting (screenshot2.PNG)

Also please find attached a screenshot (screenshot3.PNG) of what should be happening in the Maltese version as in the English version

June 26, 2017 at 5:18 pm #1305876

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending additional information. I just went to your form and in the translated version, the conditional form is working correctly for me. Please see attached screenshot. Can you please let me know if it is also resolved on your end?

July 3, 2017 at 9:35 am #1310456

simonB-6

Thanks a lot working now 🙂

July 19, 2019 at 3:52 pm #4247295

pidjouc

thanks