Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Sun Mon Tue Wed Thu Fri Sat
9:00 – 18:00 9:00 – 18:00 9:00 – 18:00 9:00 – 18:00 9:00 – 18:00 - -
- - - - - - -

Supporter timezone: Africa/Cairo (GMT+02:00)

This topic contains 3 replies, has 2 voices.

Last updated by Osama Mersal 1 year, 4 months ago.

Assisted by: Osama Mersal.

Author Posts
October 9, 2022 at 5:34 am #12207935

assafD

Tell us what you are trying to do?
We are building header menu for our website with Elementor HEader and Footer Builder so we can show it only on "Logged users". And it was working fine. As our website is i one main language - Bulgarian we install WPMl so we can translate some text coming out form plugins. And after we install it the header stops shows on logged users. We double checked and we uninstall you plugin it start working again.
Both plugins are important to us so we need to find a way to make them both work.
Thanks.
What is the link to your site?
hidden link

support-wpml.PNG
October 10, 2022 at 9:14 am #12211617

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for contacting WPML forums support. I'll be glad to help you today.

Would you please login to this sandbox site and create a test header to replicate the issue? (hidden link)

If the issue is replicable, please let me know the steps to reproduce it.

Thanks for your cooperation and patience

Regards,
Osama

October 11, 2022 at 1:06 pm #12220285

assafD

Hello. So I logged to the sanbox website and create test header and it does not work.
Here is how to reproduce it:
1. Go to Apperiance --> Elementor Header and Footer
2. Press Add new button -> put name of teh element and choose type :Header
3. Choose to be visibile to the entire website (does noт really matter teh option here)
4. edit it with Elementor and published it

It should be visible now when you are loggedin, but it seems to not working.

October 11, 2022 at 1:16 pm #12220363

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for replicating the issue. I've checked the issue and was able to fix it by the following steps.

1- Go to WPML-> Settings-> Post Type Translation
2- Set the "Elementor Header & Footer Builder (elementor-hf)" post type to "Translatable - use translation if available or fallback to default language"
3- Update the header template

After the above steps, the header appeared correctly in the default language, but it didn't show in the translated language, so I duplicated it, which fixed the issue.

Would you please check the sandbox site and let me know if the header works as expected?

Thanks for your cooperation

Regards,
Osama

The topic ‘[Closed] Conflict between WPML and Elementor Header & Footer Builder’ is closed to new replies.