This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 18 replies, has 2 voices.

Last updated by Bruno Kos 2 months, 3 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
July 6, 2019 at 1:17 pm #4155929

silmikko

Hi guys,

/en/services

On that page there are two Price Tables. For some reason those Price Tables loses some padding when I do some changes on the page or some translations with WPML. It's an easy fix but annoying to keep it on an eye and keep following that the issues doesn't come back.

hidden link

And then there are these changes too made by WPML. These tag are not on my primary language:
hidden link

The other issue is a kind oof similar. On each sub page under Services you can see this happening when ever I do some change on the pages. Actually it's enough to just enter the translation section and without doing changes but just hit Save and Exit the one of the buttons loses its' padding.

This is how the buttons should look like:
hidden link

When doing some translations or just hitting the Save and Exit this happens. This happens also always after doing some changes on the page itself:
hidden link

I have contacted Elementor support as well over these issues but they haven't found any issues on their side.

Can you help me with this?

Cheers,

mikko

July 8, 2019 at 9:37 am #4160549

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

For some reason those Price Tables loses some padding when I do some changes on the page or some translations with WPML.

Can you tell me if this issue is present only when you edit the original or translation of this particular page, or is this present even if you manage translations or originals of other pages not related to this one?

Also, can you answer which Elementor widget are using for these tables? I suspect that this might be compatibility issue of some sort and we could test this on our clean installation and possibly escalate to our compatibility team for further investigations (if you would be interested in such scenario, I will set up clean sandbox for you where you could emulate same behavior - let me know).

Regards,
Bruno Kos

July 8, 2019 at 10:12 am #4160899

silmikko

Hi Bruno,

Thank you for your reply.

So far I have only noticed this when editing the secondary language. The primary language is ready, so I haven't had any reason to make changes to this. At the moment I'm not ready to do any changes to the primary language either. All the translations are ready but just have these small issues left. My translator is just waiting for these issues to be fixed so he can export the xliff file for back up.

Price Table is Elementor Pro widget.

Carlos and I have already set up a sandbox over some other issue I had. Can you check if this is still active? If not, lets do that.

I have had DEBUG set for a while now in the wp-config.php file. Here is the debug log. Can you please make it not visual for everyone.

hidden link

Then there is this other issue with the buttons, that also loses some of the paddings. Do you think these are related to each other?

Cheers,

mikko

July 8, 2019 at 12:20 pm #4162263

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi Mikko,

They may or may not be related - however, the button issue is there and has been already escalated to our developers. The only workaround we know currently is the following:
https://wpml.org/forums/topic/elementor-format-of-buttons-changes-when-changing-language/page/2/#post-3883055

However, it has not been picked up by our developers for active development yet and unfortunately I don't have any dates on when this might happen.

As for the issue you had with Carlos, I see that it has been worked on sometime last year and are sandboxes usually expire after seven days if not used.

However, I think that we could try to prove the same issue on our sandbox, so I am attaching credentials here. Let me know if there's anything you need me to assist on the sandbox itself.

Login: hidden link
Username: demo
Password: H1OrLut50Us3

As for replicating the issue, I believe that it might be happening in the event if the original has been changed, and not translation itself. Let me know if I'm wrong. The issue I would like to test on this sandbox is the Price Table, since the other issue has been escalated.

As for the links to debug logs, have no worries, all these links are hidden from the public, only you and other WPML supporters can see them.

Regards,
Bruno Kos

July 8, 2019 at 12:46 pm #4162487

silmikko

Hi Bruno,

"As for replicating the issue, I believe that it might be happening in the event if the original has been changed, and not translation itself. Let me know if I'm wrong. The issue I would like to test on this sandbox is the Price Table, since the other issue has been escalated."

I haven't actually worked with the original translation, if you mean with the original the changes on the primary language. On this Services page the easiest way to get this happen is, for example, deleting the translated text of the first image through the translation management (I hope I get the terms right). Then saving and clearing the caches. You may see the changes on the site after this or at least you retranslate the first image.

It was only last week, I think, we made the sandbox with Carlos, not last year.

With the sand box credentials you sent me now, do you want me to rebuild the issue over there? If so, how much and what exactly I need to do over there?

Cheers,

mikko

July 8, 2019 at 1:06 pm #4162715

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Oh, I'm sorry, I did not see that ticket, but only the older one. Sure, you can try to replicate the issue here:
hidden link

On this Services page the easiest way to get this happen is, for example, deleting the translated text of the first image through the translation management (I hope I get the terms right).

As for this, you cannot actually delete the content within translation management - it only recognizes strings that need to be translated and you can either choose for the translations to be empty or add your own translations, but it is not possible to delete anything directly. You can only delete the content on translated pages if you edit them directly, avoiding translation management altogether.

Regards,
Bruno Kos

July 8, 2019 at 1:23 pm #4162799

silmikko

Hi Bruno,

I have now rebuilt the first Price Table to the sandbox you first sent me. Can you take it from here and do the translation part (you can see the translation here hidden link)? I don't really know how to go from here. My translator exported the xliff file, did the translation and then imported the file. I think something might have happened in this part since there are extra <p> tags added in the translation as you can see here (there are no <p> tags on the primary language):

hidden link

Cheers,

mikko

July 8, 2019 at 2:05 pm #4163291

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I believe I was able to reproduce the issue you're facing - can you have a look?
hidden link

This is a translation and I see some weird spacing issue below - Majatalon lakanat 12€ lisähintaan.

Can you confirm that this is the same issue you are reporting? If yes, I will escalate the whole case to our compatibility team so that they can have a look.

Regards,
Bruno Kos

July 8, 2019 at 2:41 pm #4163651

silmikko

Hi Bruno,

Great, you were able to reproduce it! That's exactly what I'm seeing on my site.

There is a easy fix to it, just add 1px bottom padding but the padding is just lost occationally when doing some translations.

How do we proceed from here?

Cheers,

mikko

July 9, 2019 at 8:13 am #4168377

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

This has been escalated to our Compatibility team and may take some debugging time, I'll get back to you as soon as I have any news or questions for you.

Regards,
Bruno Kos

July 9, 2019 at 11:13 am #4170053

silmikko

Hi Bruno,

Thank you so much.

mikko

July 9, 2019 at 12:40 pm #4170783

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

(changing Ticket status for internal purposes - please ignore)

July 11, 2019 at 6:18 am #4186247

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I have information that the fix for the pricing table issue is going out in the next release of WPML. Once this happens, can you update the plugin and test again and let me know if the issue is gone?

I cannot give you the exact date, but hopefully the new update is going out soon.

Regards,
Bruno Kos

July 12, 2019 at 8:50 am #4196603

silmikko

Hi Bruno,

That's good news. I'll test it and will let you know how it goes.

mikko

July 12, 2019 at 10:53 am #4197781

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

(changing Ticket status for internal purposes - please ignore)