This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Translated products are imported but not linked to existing default language (english) products.

Solution: The client was missing a step in the mapping. Please see screenshots from https://wpml.org/forums/topic/connect-wc-products-with-wp-all-import/#post-4448287 for how to properly map the imports.

This topic contains 7 replies, has 2 voices.

Last updated by tomv-15 1 month, 4 weeks ago.

Assigned support staff: Lauren.

Author Posts
August 23, 2019 at 12:01 pm

tomv-15

I am trying to:
Import WooCommerce product translations in a second language using WP All Import and WPML All Import Pro.

URL of (my) website where problem appears:
hidden link (for example).

I expected to see:
Linked product translations

Instead, I got:
Translated products import but not linked to existing default language (english) products.

I used two csv files and SKU as a connector

August 23, 2019 at 12:04 pm #4446639

tomv-15

The Languages are (default and secondary) : (1)Dutch (Nederlands) and (2) German (Deutsch).

These are csv files we used.

1. Items_for_WooCommerce_SHCN_NL
2. Items_for_WooCommerce_SHCN_DE

August 23, 2019 at 1:36 pm #4447661

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Please try using a unique column in the files for the connector. I have seen this happen in the past when trying to use an existing field, and specifically with sku. You can find the instructions for this column in our documentation here: https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/#how-to-prepare-csv-xml-files. Also, be sure you are selecting the mapping correctly in the WPML Add On section of the import settings.

Please let me know if that resolves the issue.

August 23, 2019 at 2:47 pm #4448247

tomv-15

Hi Laura, thanks but still the same problem. What do you mean by 'setting the mapping correctly?'

August 23, 2019 at 2:54 pm #4448287

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I have attached two screenshots. In your first import, you must set the default language. In the second import, you must map the import to the parent import (the default language).

August 23, 2019 at 3:00 pm #4448357

tomv-15

I thought i did this, I will try it tomorrow. Thanks

August 23, 2019 at 3:07 pm #4448393

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Okay great, please let me know if the results are the same after you test this.

August 23, 2019 at 9:10 pm #4449817

tomv-15

My issue is resolved now. Thank you!