This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Carlos Rojas 1 year ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 19, 2018 at 9:47 am #2748170

grettyL

Tell us what you are trying to do?

Trying to translate my homepage, I cloned it but I cannot see the connect with translation button neither in the original front page, or in the cloned page, which is in Spanish (the original one is in English)

Is there any documentation that you are following?

Experiencie and internet information

Is there a similar example that we can see?

What is the link to your site?

hidden link

September 20, 2018 at 12:57 am #2750218

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- If I understood the issue correctly, you are duplicating the page using 'Duplicate page' plugin and you can't see the 'This is a translation of' option. Is this correct?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

September 20, 2018 at 8:09 am #2751400

grettyL

1. Yes, but I also cannot see the "Connect with translation" option in the original homepage which is not a clone of a page, but I cloned this page and selected another language for the clone and I have the same problem. With other pages I CAN see this option, that's weird I believe.

2. I did it but the result is the same...

Hope to hear from you soon Carlos.

Thanks in advance.

September 20, 2018 at 5:53 pm #2752923

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Could you tell me if the issue persists if you follow the steps provided in this link: https://wpml.org/forums/topic/overwrite-with-original-language/#post-780112

Regards,
Carlos

September 25, 2018 at 9:21 am #2763158

grettyL

Hey Carlos, I tried this, the page is clonning that's correct and the translation IS WORKING but with a lot of errors, you can check here hidden link how all the images narrowed and I'm not sure how to fix them. Any other solution?

September 25, 2018 at 4:01 pm #2764670

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your message.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

September 26, 2018 at 7:39 pm #2768509

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

I inspected the site and the Translation Editor is working correctly. In case you decide to use one of the page in Spanish to be the translation of the Homepage in English, you need to delete the translation of the Homepage in Spanish.

To be more clear, delete all pages in Spanish (2 out of 3) except the one you want to be the translation for the homepage -> Delete the pages permanentily from the Trash -> Edit the remaining page in Spanish -> Use the function 'This is a translation of' -> Select the homepage in English -> Save the changes.

If the page you didn't delete in Spanish still doesn't show the option 'This is a translation of' is because it has a translation in English already.

Summarizing: This option won't appear in pages that already have a translation.

Please let me know if you need further assistance and I will be more than happy to help.
Best regards,
Carlos

September 27, 2018 at 10:36 am #2770133

grettyL

Hey Carlos it worked! Thanks,, I just have one more question, and I think this will be the last one. You can see the slider at first on top of the home page hidden link .

This I can't translate it, and as far as I know, the only way to edit (the text on the slider) is through Appearance > Customize > Header > Showcase Panel, but the problem is: the text changes in English AND Spanish, I mean, if I translate it to Spanish, the English version of the page will show the Spanish text as well.

Thanks in advance!

September 27, 2018 at 7:49 pm #2771705

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
I'm glad to hear that the issue is solved 🙂

In the case of the string in the slider you have to options:
1.- Go to WPML -> String Translation -> Translate texts in admin screens » (bottom left) -> Unfold 'theme_mods_bitunit-theme-files' -> Select 'header_showcase_title' -> Save changes.

2.- Go to WPML -> Settings -> Custom XML Configuration tab -> Add this code:

<wpml-config>
  <admin-texts>
    <key name="theme_mods_bitunit-theme-files">
      <key name="header_showcase_title" />
    </key>
  </admin-texts>
</wpml-config>

After one of the two steps above you should be able to add a translation of this string in WPML -> String Translation.

Best regards,
Carlos