This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I can't connect the homepage with it's translation using "This is a translation of" option

Solution: The cause of the issue was that it seems you started to translate (clicked in the plus (+) symbol) the Homepage in English US to English GB. When this happens a page is already created and/or reserved for this translation, that's the reason why you can't connect the GB translation to the US page.

I 'finished' the translation of the Homepage in US to GB and I titled it 'Home to delete', please follow this steps in order to solve the issue: - Go to Pages -> Pages in English GB -> Delete the 'Home to delete' page -> Remove it from the trash too -> Try to connect the Home in GB you created to the Home in US.

Relevant Documentation:

This topic contains 6 replies, has 2 voices.

Last updated by Carlos Rojas 1 year, 4 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 16, 2018 at 11:48 am #2156218

Maultrommel

I am trying to: use "Connect with translations" or "This is a Translation of"

Link to a page where the issue can be seen: hidden link

I expected to see: Pages listed.

Instead, I got: I can only link to the [gb] page to this [en] About page. The german page already seems to have translations, but "This is a translation of:" shows nothing.

May 17, 2018 at 9:36 pm #2183498

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

May 22, 2018 at 2:02 pm #2208554

Maultrommel

Memory limit set to 128M

May 22, 2018 at 5:13 pm #2210756

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

The cause of the issue was that it seems you started to translate (clicked in the plus (+) symbol) the Homepage in English US to English GB. When this happens a page is already created and/or reserved for this translation, that's the reason why you can't connect the GB translation to the US page.

I 'finished' the translation of the Homepage in US to GB and I titled it 'Home to delete', please follow this steps in order to solve the issue:
- Go to Pages -> Pages in English GB -> Delete the 'Home to delete' page -> Remove it from the trash too -> Try to connect the Home in GB you created to the Home in US.

Could you tell me the result of this steps?

Best regards,
Carlos

May 23, 2018 at 7:56 am #2213000

Maultrommel

Thank you Carlos - I will test that today.

May 23, 2018 at 8:03 am #2213094

Maultrommel

Yes - that worked.

May 23, 2018 at 3:04 pm #2216489

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML.
Best regards,
Carlos