Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by erikaA-3 2 years, 5 months ago.

Assigned support staff: Mladen Andrejic.

Author Posts
July 12, 2017 at 9:11 am #1317539

erikaA-3

I am trying to:

URL of (my) website where problem appears:

I expected to see:

Instead, I got:

Steps to duplicate the issue:

I have tried with 3 languages
when Submitting the form in the secondary language fails. This producess the below console error:
xxxxx/wp-json?lang=it/contact-form-7/v1/contact-forms/XXX/feedback 404 (Not Found)

URL: ***
Secondry language url: ***

July 12, 2017 at 10:36 am #1317632

Mladen Andrejic

Hello,

Can you please go to WPML > Languages and find "Store language cookie for AJAX" option and activate it.

This should help you in this case.

Thanks.

July 12, 2017 at 12:37 pm #1317740

erikaA-3

I have tried this but still i get same issue.

July 13, 2017 at 3:32 am #1318338

erikaA-3

Hi Mladen,

i will be appreciate if you can respond me asap.

July 13, 2017 at 5:33 am #1318354

Mladen Andrejic

Hello Erika,

## Can you please check if the problem persists when

- All non WPML Plugins are disabled
- Theme is set to default Twenty Seventeen

## Activate WordPress debug.log and see if there are any errors displayed? Here are the instructions for activating it : https://wpml.org/documentation/support/debugging-wpml/

Please paste here any errors that you see in the WordPress debug.log

Thanks.

July 13, 2017 at 11:50 am #1318709

erikaA-3

Hi,

i am trying this but its not working can you solve my problem or not. look screenshots in details.

July 13, 2017 at 12:03 pm #1318725

Mladen Andrejic

Hello,

Can you please go to WPML > Languages and under "Language URL Format" choose "Languages in directories" and see if this helps?

Thanks.

July 14, 2017 at 4:34 am #1319298

erikaA-3

Thanks Mladen.
It's working.

However i have created 2 sub domains and try to configure however its not validating. i already refer your tutorial https://wpml.org/2016/04/use-wpml-different-domains-per-language/.

July 14, 2017 at 7:43 am #1319402

Mladen Andrejic

Hello Erika,

Since this is a different issue, may I please ask you to create another ticket about that?

Thanks.

July 14, 2017 at 8:50 am #1319455

erikaA-3

okay. But before let me know how can I edit the previous post. OR remove our website URL from old threads and add any dummy URL.

July 14, 2017 at 9:58 am #1319522

Mladen Andrejic

Hello,

I edited first post where you had URL pasted. Let me know if anything else needs to be removed.

Thanks.

July 14, 2017 at 10:14 am #1319534

erikaA-3

Please remove my screenshots as well. Then I am good.

July 14, 2017 at 10:41 am #1319555

Mladen Andrejic

Hello,

It's done 🙂

July 14, 2017 at 11:01 am #1319578

erikaA-3

Thanks for your help.