Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

No supporters are available to work today on this forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

This topic contains 18 replies, has 2 voices.

Last updated by tsz-lungL 3 weeks, 3 days ago.

Assigned support staff: Raja Mohammed.

Author Posts
April 7, 2021 at 10:39 pm #8486355

tsz-lungL

After installing Confact Form 7 Multilingual plugin, the forms in the admin platform disappeared.

I have read your our post to do the troubleshooting
https://wpml.org/forums/topic/cf7-forms-disappeared-after-cf7-multilingual-plugin-was-installed/

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information

However, it took me hours of set language information and it is still loading.
It doesnt work.

How to solve the problem?

April 8, 2021 at 7:30 am #8488271

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello there,

You have mentioned "However, it took me hours of set language information and it is still loading." Probably the process has encountered an error. It would be good if you can provide me with the WordPress debug.log (not WPML debug information).

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to (incase if you dont find the code proceed with adding the code below):

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Once the log is enabled try running the Set language information again, Check if you still encounter any issue, In this case, the errors will be saved to a debug.log log file inside the /wp-content/ directory.

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in the discussion).

Regards
Raja

April 8, 2021 at 11:35 am #8491171

tsz-lungL

Thanks for your answer. After I enable the debug function, for unknown reasons, I can do set language information without problems now. However, after I did the 4 steps, I cannot still find the contact form in my admin.

I still give you the link of debug here: https://pastebin.com/u18CLb6Q

What should I do?

April 8, 2021 at 11:37 am #8491197

tsz-lungL

And I only have 3 forms. Would it be more efficiency if I go to phpmyadmin to find the database of the form and manual change the language?

If so, can you tell me where can I find it in my database?

(I dont know if this method works or not, I am a beginning of wordpress)

April 9, 2021 at 4:58 am #8498095

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

It is not a feasible option to set the information in the database as they are set in multiple locations.

May I know the number of forms that are displayed after disabling the WPML plugin ? , If the count is still different, Probably the set language information needs to run again.

April 9, 2021 at 2:10 pm #8502807

tsz-lungL

After I disabled the WPML plugin, I still cannot see the forms. Zero forms in admin platform.

But I can still use the form which is already embeded in my pages. So the forms still exist.

April 9, 2021 at 9:27 pm #8504515

tsz-lungL

And I have run again the set language information, it is done but nothing changed on the contact form

April 12, 2021 at 4:25 am #8512869

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

You have mentioned => "After I disabled the WPML plugin, I still cannot see the forms. Zero forms in admin platform." This means probably WPML is not related in this case, If it was related to WPML By disabling WPML the forms should be visible again If not the form should have been deleted or the form in the front end should be rendered from the trash.

However to be more precise about the issue, I might need to take a closer look, It would be better if you can share temporary access to the site so that I can check this quickly. Also, share the page url where you are still able to see the form in the front end.

I am enabling private fields to securely share the details.

Regards
Raja

April 13, 2021 at 5:23 am #8521925

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I am not able to access the site using the login details, It throws some error.

I checked the forms I see they are translated in the other languages as well. Not sure what really is the issue in this case. As you have mentioned disabling WPML does not show the forms are you looking for any other forms that is already created yet do not display on the admin side?

Regards
Raja

Screenshot 2021-04-13 at 10.50.17 AM.png
April 13, 2021 at 8:47 am #8523189

tsz-lungL

The issue is that I cannot find the forms in admin platform anymore.
So in future I cannot edit it.

I created the forms before I installed WPML contact form plugin

Disabling WPML does not show the forms I am looking for any other forms that is already created yet do not display on the admin side

April 13, 2021 at 8:48 am #8523193

tsz-lungL

Sorry I made a mistake in login credentials. Now I edited the private message. Please use it.

April 13, 2021 at 12:53 pm #8525409

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

When I try to Set the language Information It encounters a server error, The details about the error should be logged in the server error log. Please get assistance from your hosting provider and get the latest error logs. you can upload the log to a file sharing service and share the link here. That should help us identify the exact issue.

April 19, 2021 at 4:28 pm #8574523

tsz-lungL

Sorry for a few days delay.
The hosting provider cannot provide server error log. How can I get it?

April 19, 2021 at 4:57 pm #8574777

tsz-lungL

I have not set server error in .htaccess according to the instruction given by the host provider

hidden link

I added these code into .htaccess and click set language information

php_value error_reporting 2047
php_value error_log chinaworker.info/httpd-error.log
php_value log_errors_max_len 52428800

But I cannot find a error log produced in the path. Can you tell me what to do?
If you need FTP access I can provide

April 20, 2021 at 10:47 am #8580241

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Please share FTP access let me check if I can get the relevant error logs, Without the error logs it is hard to debug this case. If you have disabled the error logs enable it for the time being while the issue is tested.

Regards
Raja