Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am using the Contact Form 7 plugin but it doesn't show the translation

Solution: 1. Please follow the documentation in the link below: https://wpml.org/documentation/plugins-compatibility/using-contact-form-7-with-wpml/

2. Make sure that the translation is fully published and not in "waiting for translator" or "in progress" status: https://wpml.org/forums/topic/contact-form-7-multilingual-dont-show-the-translation-2/#post-4315633

This topic contains 5 replies, has 2 voices.

Last updated by smartwebasia 4 months, 1 week ago.

Assigned support staff: Mihai Apetrei.

Author Posts
July 30, 2019 at 7:17 am

smartwebasia

Hi,

My previous topic has been deleted by your staff Raja ...No reason, so i try again.

Im trying to use Contact Form 7 Multilingual.
I followed the doc: https://wpml.org/documentation/related-projects/mailchimp-for-wordpress-multilingual/

All seems OK (see screenshot) but the translation don't appear in front-end.
I don't understand why... Same content EN/FR appears despite of my translations in Translations queue page.

hidden link
hidden link

Can you please check or lead me to a solution?

Thank you

July 30, 2019 at 10:29 am #4306911

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

From what I can see, you were following the MailChimp documentation but I see that you are referring to translating a contact form 7 so I think you should follow this other documentation in the link below:
https://wpml.org/documentation/plugins-compatibility/using-contact-form-7-with-wpml/

Can you please take a look over that and see if the steps there solve the issue for you?

Please let me know. I will be waiting for your response.

Kind regards,
Mihai Apetrei

July 31, 2019 at 2:31 am #4311243

smartwebasia

Hi,

My bad...I sent the wrong link, of course I followed this doc: https://wpml.org/documentation/plugins-compatibility/using-contact-form-7-with-wpml/ and this is not working for me.

Can you please check?

Thank you

July 31, 2019 at 3:03 pm #4315633

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for your patience.

If I change the flag at the top to French (in the backend) and then I go to the contact forms page (hidden link), it shows me "No items found."

If we go in WPML > Translation management and filter by Contact Form, we can see that newsletter form is in the "in progress" status and the other one is in "waiting for translator" status so none of them were completely saved and published.

The form is currently assigned to you as a translator so can you please edit the form, make sure that all the fields are translated and then try to save it one more time?

If that doesn't work, can you please copy-paste me the text that you want in the new form so that I won't have to manually type it out and I can try to cancel the current translation job and then try to translate it with my user?

Please let me know.

Kind regards,
Mihai

August 1, 2019 at 10:04 am #4320359

smartwebasia

Hi there,

Very interesting answer Mihai and very well detailed.

I made some tests and now I understand the Translation status must be "Complete" in order to work properly.

Thank you guys.

August 1, 2019 at 10:05 am #4320361

smartwebasia

My issue is resolved now. Thank you very much! 🙂