We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 3 voices.

Last updated by Bigul 1 month ago.

Assigned support staff: Bigul.

Author Posts
September 14, 2019 at 1:46 pm #4572757

promaxE

Hello,
i created a form on Turkish selected. after i used on my page and it works fine okay. but i cant see on contact forms?

interesting.

please check and help me. i should change on somethings but i cant do that.

September 16, 2019 at 10:44 am #4579143

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I am not 100% sure that I fully understand what you mean.

From my understanding, you have a form that you are using already but you say that you are not seeing it in the backend?

1. Can you please let me know what is the link of the page on your site where you are using that form?

2. I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

September 18, 2019 at 8:44 am #4593839

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I am Bigul from WPML support team. Mihai is not available today. So I am taking care of this ticket. Hope it will be okay for you.

I went through the site backend and frontend. But sorry, not able to reproduce the issue exactly. So please let me know the exact steps to reproduce the issue.

--
Thanks!

Bigul

September 18, 2019 at 10:49 am #4595237

promaxE

Hi,
check please;

September 18, 2019 at 6:30 pm #4599529

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Clear all types of caches including server-side caches

2) Go to WPML>>Support page

3) Click on Troubleshooting link (blue link in the middle of the page)

4) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Recreate ST DB cache tables

--
Thanks!

Bigul

September 19, 2019 at 8:59 am #4602847

promaxE

Hello Bigul,
yes i do that your all told to me. but the same, not show on turkish.

September 19, 2019 at 4:52 pm #4607439

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. It requires further checking. So please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

September 21, 2019 at 11:58 am #4615863

promaxE

Of course please do soemthings and solved already because we waiting for your help 4-5 days until now.

September 22, 2019 at 4:37 pm #4618987

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for your permission. I am getting the expected result on my local copy after the following steps. Somehow the translation job is missing for the Turkish Subscription form.

1) Visit WPML>>Translation Management dashboard
2) Choose *Sign-up form* and resend it for translation
3) Send the translation job from Translation Basket
4) Visit WPML>>Translations
5) Choose *Sign-up form* and translate the form

Please check the attached images for more details.

--
Thanks!

Bigul

September 23, 2019 at 10:56 am #4622521
promaxE

please fixed this error ;

Howdy!

Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

In this case, WordPress caught an error with one of your plugins, WPML Translation Management.

First, visit your website (hidden link) and check for any visible issues. Next, visit the page where the error was caught (hidden link) and check for any visible issues.

Please contact your host for assistance with investigating this issue further.

If your site appears broken and you can't access your dashboard normally, WordPress now has a special "recovery mode". This lets you safely login to your dashboard and investigate further.

hidden link

To keep your site safe, this link will expire in 1 day. Don't worry about that, though: a new link will be emailed to you if the error occurs again after it expires.

Error Details
=============
An error of type E_ERROR was caused in line 45 of the file /var/www/html/wp-content/plugins/wpml-translation-management/classes/records/class-wpml-tm-icl-translations.php. Error message: Uncaught InvalidArgumentException: Unknown column: id_type_prefix or invalid id: a:2:{s:10:"element_id";N;s:11:"type_prefix";s:4:"post";} in /var/www/html/wp-content/plugins/wpml-translation-management/classes/records/class-wpml-tm-icl-translations.php:45
Stack trace:
#0 /var/www/html/wp-content/plugins/wpml-translation-management/classes/records/class-wpml-tm-records.php(138): WPML_TM_ICL_Translations->__construct(Object(WPML_TM_Records), Array, 'id_type_prefix')
#1 /var/www/html/wp-content/plugins/wpml-translation-management/classes/class-wpml-translation-job-factory.php(72): WPML_TM_Records->icl_translations_by_element_id_and_type_prefix(NULL, 'post')
#2 /var/www/html/wp-content/plugins/wpml-translation-management/classes/menu/translation-queue/class-wpml-translations-queue.php(569): WPML_Translation_Job_Factory->create_local_job(NULL, 'ru', NULL, 'post_mc4wp-form')
#3 /var/www/html/wp-content/plugins/wpml-translation-management/classes/menu/translation-queue/class-wpml-translations-queue.php(40): WPML_Tra

New threads created by Bigul and linked to this one are listed below:

https://wpml.org/forums/topic/an-error-of-type-e_error-was-caused-in-line-45-of-the-file/

September 23, 2019 at 11:21 am #4622979

promaxE

hello,
i see for turkish subscribe form here. how can i remove it ? its unneccessasry so.
yes now done. i did do that like process but not work but now ok.

please remove all unneccessary things on my page and if has other where.

thank you.

September 23, 2019 at 5:10 pm #4625841

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. But sorry, I am a bit confused about the following. Would you like to remove the Turkish Subscribe form? Please share more details about it for a better understanding.

i see for Turkish subscribe form here. how can I remove it ? its unnecessary so.
yes now done. I did do that like process but not work but now ok.

please remove all unnecessary things on my page and if has otherwhere.

Please note, I have opened a new ticket for the An error of type E_ERROR issue. Because as per our support policies, we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket. Thank you for your understanding.

--
Thanks!

Bigul

September 30, 2019 at 2:34 pm #4665337

promaxE

yes i want remove Turkish Subscribe form, after i cant translated and use it. i choise all time original way.

October 1, 2019 at 9:21 am #4670123

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. I have deactivated the MailChimp for WordPress Multilingual plugin now. Then the Subscriber form is showing in English in Turkish pages. Please check the attached images for more details and let me know your feedback.

--
Thanks!

Bigul

October 2, 2019 at 1:16 pm #4680419

promaxE

hello,
1- i translated subscribe form for turkish but not show on front translated.
2- i see turkish subscribe form on admin, should i remove it? how can i delte that?

The topic ‘[Closed] contact form losed’ is closed to new replies.