Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Contact Information widget strings are not listing for the translation

Solution: Monstroid2 Contact Information widget strings are not listing for the translation in WPML>>String Translation. It worked after the following workaround.

1) Visit WPML>>String Translation, choose *admin_texts_widget_monstroid2_contact_information_widget* from *Select strings within domain* and delete the strings
2) Open *wpml-config.xml* of *wp-content\themes\monstroid2* for edit
3) Add the following codes after line no *25*

<key name="widget_monstroid2_contact_information_widget">
      <key name="1">
        <key name="title"/>
        <key name="contact_information">
          <key name="item-0">
            <key name="icon"/>
            <key name="value"/>
          </key>
          <key name="item-1">
            <key name="icon"/>
            <key name="value"/>
          </key>
          <key name="item-2">
            <key name="icon"/>
            <key name="value"/>
          </key>
          <key name="item-3">
            <key name="icon"/>
            <key name="value"/>
          </key>
        </key>
      </key>
</key>

4) It should be between ** and **
5) Visit WPML>>String Translation again
6) Change the languages of newly registered strings to French(the default language)
7) Translate the Strings

Relevant Documentation: https://wpml.org/documentation/support/language-configuration-files/#admin-texts

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by francoisP-2 4 years, 7 months ago.

Assigned support staff: Bigul.

Author Posts
April 21, 2017 at 5:30 pm #1259243

francoisP-2

Hi!

I scanned the theme for strings but can't find the ones from the Contact Information widget in the footer area of my Monstroid2 site.

See page here, bottom right: hidden link

Thanks.

François

April 24, 2017 at 10:03 am #1260108

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi ,

Thank you for contacting the WPML support. We are happy to help you.

Hope you have tried the following steps. If not please try it after a full site backup.

- Visit "WPML>>Theme and plugins localization".
- Make sure that "Translate by WPML." is active.
- Scroll down to "Strings in the theme" and click on "Scan the theme for strings".
- Scroll down to "Strings in the plugins", select the plugin you want to scan and click on "Scan the selected plugins for strings".
- Once you followed the above steps go under "WPML>>String Translation". All strings available for translation should display in the table you see there.

Documentation:
https://wpml.org/documentation/getting-started-guide/string-translation/

https://wpml.org/documentation/getting-started-guide/theme-localization/

Please search the desired strings from WPML>>String Translation, may these strings will be registered under the *Widget* string domain.

I have a request. Please do the following steps after a site backup for the expected performance of your site.

1) Please upgrade MySQL to 5.6, the minimum required MySQL version for WPML. Check this article for more details -- https://wpml.org/home/minimum-requirements/

2) Increase *WP Memory Limit* to *128*(the minimum required memory limit for WPML) or more. Please check the following link for more details

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

3) Increase *MaxInputVars* of the PHP configuration settings to *5000* or more

--
With Regards

Bigul

April 24, 2017 at 7:04 pm #1260681

francoisP-2

Hi Bigul,

Followed instructions and strings are still missing.

Thanks.

Regards,

François

April 25, 2017 at 12:34 pm #1261275

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi ,

Thank you for the details. Please share me screenshots of your Widgets settings(from Appearance>>Widgets) for more details.

It would be nice if you can provide me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

In this case, the errors will be saved to a debug.log log file inside the /wp-content/directory. Please replicate the steps and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in discussion).

--
With Regards

Bigul

April 26, 2017 at 8:08 pm #1262713

francoisP-2

Hi Bigul,

I enabled the debug log and it's empty.

Please see attached screenshot of Contact Information widget.

Thanks.

François

contact-info-widget-1.jpg
April 27, 2017 at 4:08 pm #1263580

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi ,

Thank you for the updates. I would like to access admin area of your site for further checking. Please fill the private details fields after a full site backup. Check the following links for more details about private information sharing.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue locally.

--
With Regards

Bigul

May 1, 2017 at 6:01 am #1265258

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thank you for the login information. I made duplicator copy of your site now. Will debug it locally soon and get back to you. Please wait.

--
With Regards

Bigul

May 2, 2017 at 6:57 am #1265866

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Please try the following steps after a site backup and let me know your feedback.

1) Visit WPML>>String Translation
2) Click on *Translate texts in admin screens »* link on the bottom of the String Translation Screen
3) Then choose *widget_monstroid2_contact_information_widget* option and select the strings(Value) under *contact_information*
4) Then click on *Apply* button
5) Visit WPML>>String Translation again
6) Change the languages of newly registered strings to French
7) Translate the Strings

Please check the attached images for more details.

--
With Regards

Bigul

2017-05-02_1228.png
2017-05-02_1212.png
2017-05-02_1149.png
2017-05-02_1150.png
2017-05-02_1159.png
May 2, 2017 at 2:06 pm #1266319

francoisP-2

Hi Bigul,

Great instructions, followed them with no problem.

But the info is still appearing in French in the footer, the translations are not picked up, see here bottom right: hidden link

I can't find what I did wrong.

Thanks for your help.

Regards,

François

May 3, 2017 at 10:12 am #1266992

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thank you for the updates. Before recommending the workaround I have only tested the following string and it was working for me. Something is wrong with the other Confirmation Widget strings. I will do more debugging on it and get back to you soon. Please wait.

1 Place du Commerce
Bureau 435
Verdun, QC H3E 1A2

--
With Regards

Bigul

May 4, 2017 at 1:50 pm #1268224

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Please try the following steps after a backup and let me know your feedback.

1) Visit WPML>>String Translation, choose *admin_texts_widget_monstroid2_contact_information_widget* from *Select strings within domain* and delete the strings
2) Open *wpml-config.xml* of *wp-content\themes\monstroid2* for edit
3) Add the following codes after line no *25*

<key name="widget_monstroid2_contact_information_widget">
      <key name="1">
        <key name="title"/>
        <key name="contact_information">
          <key name="item-0">
            <key name="icon"/>
            <key name="value"/>
          </key>
          <key name="item-1">
            <key name="icon"/>
            <key name="value"/>
          </key>
          <key name="item-2">
            <key name="icon"/>
            <key name="value"/>
          </key>
          <key name="item-3">
            <key name="icon"/>
            <key name="value"/>
          </key>
        </key>
      </key>
    </key>

4) It should be between *</key>* and *</admin-texts>*
5) Visit WPML>>String Translation again
6) Change the languages of newly registered strings to French
7) Translate the Strings

--
With Regards

Bigul

2017-05-04_1921.png
2017-05-04_1917.png
May 4, 2017 at 4:24 pm #1268425

francoisP-2

Hi Bigul,

Great, it works!

Why can't we add the strings from "Translate texts in admin screens"?

Thanks for your help.

Regards,

François