This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
The contact content is not showing in the translation editor.

Solution:
I added the following shortcode to your WPML -> Settings -> Custom XML Configuration:

<shortcode>
<tag>insomnia_contacts_us</tag>
<attributes>
<attribute>insomnia_contacts_us_name</attribute>
<attribute>insomnia_contacts_us_text</attribute>
<attribute>insomnia_contacts_us_icon</attribute>
</attributes>
</shortcode>

Now the fields are showing up on your translation editor.

This topic contains 13 replies, has 2 voices.

Last updated by Lauren 1 year ago.

Assigned support staff: Lauren.

Author Posts
August 24, 2018 at 11:02 am #2672824

tarcisioC

I am trying to:
translate the contact page to english

Link to a page where the issue can be seen:
but you have to add these 2 lines in you local hosts file because the website is not published yet
191.252.107.57 serralheriacoelho.com.br
191.252.107.57 hidden link

hidden link

I expected to see:
The fields: telefone, e-mail, Endereço translatable

Instead, I got:
no strings to be translated

the other guy from the support included custom xml settings for another page and it worked, how do I do it for contact page field elements???

August 24, 2018 at 6:35 pm #2674077

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Can you please tell me how those boxes for phone, email, etc are created? Are you using a page builder? If so, which one and what type of element are you adding? It is likely that you need to add the page builder shortcodes to WPML -> Settings -> Custom XML Configuration.

Depending on the page builder, you can sometimes view the page editor in the traditional WordPress editor and view the Text tab do see the shortcodes. However, some page editors lose the content when you do this, so please proceed with caution.

If you need further assistance with adding shortcodes, please see https://wpml.org/documentation/support/language-configuration-files/ and let me know if you need further assistance.

To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.

NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

August 26, 2018 at 7:58 pm #2676498

tarcisioC

It's been 2 weeks I'm trying to finish this project, can you please help me?

August 27, 2018 at 12:55 pm #2678156

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please see my previous reply and provide me the additional information about how the content is created so that I can further assist you.

In addition, please update WordPress to the latest release. Please also try increasing the WP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it above the line /* That's all, stop editing! Happy blogging. */

September 3, 2018 at 8:24 pm #2700892

tarcisioC

Yes, I'm using page builder WPBakery Page Builder, I don't know how to find the shortcode the other guy inserted custom xml configuration easily. How can I provide you the private informations to access?

September 4, 2018 at 10:03 pm #2704790

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

September 5, 2018 at 2:41 pm #2707689

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for allowing me access. I added the following shortcode to your WPML -> Settings -> Cusotm XML Configuration:

<shortcode>
<tag>insomnia_contacts_us</tag>
<attributes>
<attribute>insomnia_contacts_us_name</attribute>
<attribute>insomnia_contacts_us_text</attribute>
<attribute>insomnia_contacts_us_icon</attribute>
</attributes>
</shortcode>

Now the fields are showing up on your translation editor. Please let me know if you need any further assistance and I will be happy to help.

September 6, 2018 at 10:18 am #2710269

tarcisioC

Excellent, how can I find shortcode field's name in other cases, then I don't need to contact the support again, for example, I have the same issue which is the last one in services page, there are 3 text elements which don't appear in translation page? Can you help me to figure out it by myself?
thanks

September 6, 2018 at 6:05 pm #2711874

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Sure thing! Go to edit the page where the content is and click to use the classic mode editor instead of the page builder editor. Then you can see all of the shortcodes and add them to the WPML -> Settings -> Custom XML Configuration. Please see screenshots for further explanation. Let me know if you need any further assistance.

September 14, 2018 at 12:28 pm #2735317

tarcisioC

Hi,

I tried to insert the shortcode as you suggested in many different ways, but the fields don't appear in the translation page:

<shortcode>
<tag>insomnia_services</tag>
<attributes>
<attribute>insomnia_icons</attribute>
<attribute>insomnia_name</attribute>
<attribute>insomnia_text</attribute>
</attributes>
</shortcode>

I inserted... removed, changed the place but no success, can you tell me why please?

thanks

September 14, 2018 at 2:31 pm #2735720

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

The login link that you previously provided is no longer working for me. I'd like to login and take a look at the config file. Can you please double check and update the credentials as needed?

Also, did you update the WP Memory as I mentioned in an earlier reply?

September 14, 2018 at 6:51 pm #2736496

tarcisioC

The login is still the same:
hidden link

but you need to add these 2 lines in your local hosts file because the site isn't published yet.
191.252.107.57 serralheriacoelho.com.br
191.252.107.57 hidden link

I'll check the WP Memory

September 14, 2018 at 8:39 pm #2736667

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Everything looks good in the config settings. The original page just needed to be updated. I did that and now the fields are showing up in the translation editor.

Please let me know if you need any further assistance and I will be happy to help.

September 28, 2018 at 9:06 pm #2774880

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Confirmed that this is resolved.