Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 3 voices.

Last updated by Marcel 4 months, 3 weeks ago.

Assigned support staff: Marcel.

Author Posts
May 4, 2022 at 8:57 pm #11154591

benjaminC-34

I have a custom field in content and theme settings.

When I edit the content of the field group in one language, it changes it in another language or removes the content entirely. They keep conflicting with each other.

Please help me fix this.

content-theme.jpg
May 4, 2022 at 10:28 pm #11154733

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

You are using ACF for creating those field groups, correct?

Now, there are two methods for translating ACF with WPML:

1) By using our ACF Multilingual Addon and translating the fields with the WPML Translation Editor when translating your pages and posts. In this case, the field groups should be set to not translatable.

2) Disabling the ACF Multilingual Addon and translating fields manually on the WordPress Editor. In this can, you further can translate field groups, but this would only be needed in order to translate the backend strings of ACF.

Please verify if either one of those methods solves the issue for you.

Best regards
Andreas

May 4, 2022 at 10:52 pm #11154755

benjaminC-34

Hi Andreas,

They are an options page we created using ACF. I have the ACF Multilingual Plugin installed. I don't use WPML Translation because I like to do it all manually.

I set 'Field Groups' in WPML settings to 'Not Translatable'. Then I went to the option page and edited the content. When I updated the fields, all of the content disappeared.

I then tried to deactivate the ACF Multilingual plugin and it's doing the same. All the content in the fields disappear when I click update.

content-gone-updated.jpg
May 4, 2022 at 11:50 pm #11154899

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better for a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “All In One WP Migration” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

The steps are also shown in this video: hidden link

Best regards
Andreas

May 6, 2022 at 4:01 am #11164313

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for setting up staging, but sadly I am not able to install any plugins on this site, without having FTP access.

Apart from that, I have edited the title of the page Content and Theme Settings by switching the admin bar language to EN, FR, and DE and do not see any issue with saving the fields.

Could please verify and provide me with more detailed steps about how I can recreate the issue?

Best regards
Andreas

May 6, 2022 at 10:20 pm #11171265

benjaminC-34

Hello Andreas,

Unfortunately, I'm not able to provide FTP access.

Please make sure you are in the Leadership options page within the Content and Theme Settings Menu.

I verified to make sure it is still happening. If you check the English Leadership page, everything is correct, and then when you switch the language using the top menu, fields are empty where there was translated content before.

1. I went into the French version of the site. Added some text in the blank field group. Updated.

2. Check front end of website. It looks fine on the front end. But then switch to a different language, and the order of the photos or text has changed on the two people in the middle. The order and text is supposed to be uniform (the same) across all languages (besides text being translated).

3. The issue is that when I make an update to one, it changes the order of images on a different language.

My suggestion to duplicate the experience is try to make all of the leadership pages uniform with imagery and text and check the front end. /leadership/

Steps are in screenshots.

switch-languages-after-update.jpg
step-2-fill-in-fields.jpg
step-1-french-fill-in-fields.jpg
May 7, 2022 at 2:42 am #11171931

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I had now adjusted the translation preference settings for this field group.

Repeater Fields should always be set to "copy once" - all other fields of this group I have set to "not translate" as we are actually not able to translate them with the WPML Translation Editor if it is an option page.

I could still see an issue when it comes to the Call-to-Action field.

Then I delete all the field group translations and set field groups to not translatable and it seems this solved the issue.

Could you please test again?

Best regards
Andreas

May 9, 2022 at 7:56 pm #11184279

benjaminC-34

Hi Andreas,

Thank you for the update. I confirmed it is working in the URL I gave you.

I made the page updates again on the LIVE site and they are suddenly working without me changing any WPML settings as you had suggested.

Not sure what happened there....but THANK YOU. The leadership is being translated for every language again on the LIVE site with the correct headshot and no content is disappearing when I click update. Since I don't know how the problem got solved on the live site, I'm worried the problem will return.

Would you be able to show me a screenshot of where you made those settings changes? Was it CF Translations?

May 10, 2022 at 4:28 pm #11191553

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

my name is Marcel and I will take over your ticket, as Andreas is not available today.

Yes, Andreas configured the ACF fields on "Custom Fields" and set the translation preference there. So it should don't happen for that specific field again.

If you need to configure other fields, you can find them as mentioned here: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#making-acf-fields-translatable

Best Regards
Marcel

May 10, 2022 at 7:41 pm #11192667

benjaminC-34

Hi Marcel,

So I began doing those changes in ACF.

Now I made a content update to the French translation of the leadership page on the live site and got this image for the front end (everything is now blank). As soon as I clicked update in French, the content switched to English and disappeared from the French domain front end. But the text is still there in the backend.....

I am currently unable to duplicate this issue on the server I provided you.... 🙁

front-end-blank.jpg
May 11, 2022 at 7:48 am #11195463

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

I can't reproduce the issue either. I can see content loading on the page.

The live page shows an error in JS console, which seems not to be caused by WPML. It looks like a JS library.

I suggest you increase your WP_MEMORY_Limit first and fix writing permission as shown on the Backend admin notice. You may need to get in touch with your hoster for it.

Add this code to your wp-config.php to increase WP memory:

define('WP_MEMORY_LIMIT', '256M'); 

Paste it just before "That's all, stop editing! Happy blogging".

See here for more information https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, which means, with a default theme and no other plugins installed.

Best Regards
Marcel

The topic ‘Content and Theme Settings CF’ is closed to new replies.