This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Bobby 5 months, 2 weeks ago.

Assigned support staff: Bobby.

Author Posts
May 1, 2019 at 2:01 pm

Julia

I am trying to: Edit the content and images on the other languages

Link to a page where the issue can be seen:

watch the 2 screenrecordings in this folder:
hidden link

May 1, 2019 at 8:05 pm #3719715

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

I created 2 test pages and i was not able to replicate the issue but i was able to see it on the pages you show in the video.

if possible please go to Pages->Edit the default language of the Tiendas page and then click on the "pencil" for the Spanish translation

this will open in the Translation Editor which is only at 2% and that is what i believe is causing this issue , please translate it within the Editor until 100% and save

then try changing the pictures again from the backend and let me know your results please

May 2, 2019 at 6:09 pm #3728089

Julia

Hi Bobby,
this problem started to appear a few weeks back.

Our content in the different languages is not exactly the same, so often we edit the Spanish page directly without going through the WPML translation editor. This was absolutely no problem before, but now it does not work.

Now if we try to edit a page, it will overwrite the existing Spanish content with the English content, so we are absolutely blocked from making any modifications.

Following your solution we would have to redesign and copy and paste content for the entire site, so this is not the solution.

I also tried your solution and changed one word, but it did not save either.

I have also written to Enfold, but they say that the problem is on your side.

Please provide another solution. We cannot EDIT any page on our website.

This is very urgent,
kind regards,
Julia

May 3, 2019 at 7:16 am #3731411

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

i am testing this locally and will update you once i have some results as i believe this could be happening due to a 3rd party plugin.

May 4, 2019 at 1:54 am #3738421

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

please try the following

Go to plugins-> activate " Classic Editor" (installed it for test purposes, it blocks Guttenberg editor)

then go to any of the translation pages for "Stores" and edit , you should now see the translations change as expected.

review the following one that i did as a test in the Spanish version (screenshot) [i have since reverted the change so you can test it as well ]

May 6, 2019 at 10:17 am #3746959

Julia

Hello Bobby,
thanks for your message. Yes, with the Classic Editor plugin it works now. But another issue appeared, we cannot upload any images to the Media DB. First it said "Http error" and now it says "The uploaded file could not be moved to wp-content/uploads/2019/05".

Also the Backup plugin, UpdraftPlus, now says: The 'Backup Now' button is disabled as your backup directory is not writable (go to the 'Settings' tab and find the relevant option).
I assume this is because you are running some tests?

Thanks,
Julia

May 6, 2019 at 8:04 pm #3752491

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi Julia,

I am actually not doing any tests on your live site , all tests were done on a staging enviroment on our cloudways server which is separate from the live site.

I did however take a quick look at the issues you mentioned above and i can see that Backup Now is enabled within updraft plus and also the media upload issue remains even with WPML deactivated.

i believe it is not related to WPML as deactivating does not resolve the issue , additionally the only change done on your live from my side as far as testing the site was to install "Classic Editor"'

Additionally i did a quick search on google and there are a few results regarding this error for the media

hidden link

hidden link

https://wordpress.org/support/topic/the-uploaded-file-could-not-be-moved-to-wp-content-uploads/

let me know your results please

May 8, 2019 at 3:50 pm #3768659

Julia

Hi Bobby,

I spoke to our Hosting provider and they said we had reached the maximum number of files, more than 260000. We found a lot of files in the Object folder of Cache, and we are now deleting them.
This should fix the image upload problem, and maybe also the problem with the new editor?

I will try it tomorrow morning once the majority of the files are deleted.
Any advice how to correctly use Cache plugins with WPML?
Thank you,
Julia

May 8, 2019 at 10:57 pm #3771477

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

you can find all compatible plugins with WPML here
=> https://wpml.org/documentation/plugins-compatibility/

we also have the following documentation on W3 Total Cache
https://wpml.org/documentation/plugins-compatibility/optimize-multilingual-website-performance-using-w3-total-cache/

The topic ‘[Closed] Content changes in translated languages are not saved’ is closed to new replies.