This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by alecC 1 month, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
June 24, 2019 at 7:34 pm

alecC

I am trying to:
edit & update content via translation manager after recent WPML updates on our staging environment (updating from WPML 3.8.x to 4.2.x (latest releases)
Link to a page where the issue can be seen:
hidden link
I expected to see vs. Instead, I got:
after editing the English translation the content within the translation manager is being correctly saved, however not or only partially shown on frontend, while some parts revert to the original language. When I edit the original content via the regular page (i.e. Page Builder), after saving the original content disappears from the translation manager.
Here is a chronological description of the process (letters in brackets refer to the attached screenhots):
1. Case:
1.1. Check WPML Backend of a particular page: all necessary content fields present. (a)
1.2. Make a change in the German original and update. (b)
1.3. Go into WPML, „translate“ this change into english and update.
2. Check:
2.1. Error#1, frontend: englisch translation change has been ignored.
2.2. Error#2, WPML backend: content field, in which the changes took place are no longer available for translation, neither on the original German left side, nor on the englisch right side of the screen. (c)
3. DoubleCheck:
3.1. Try to „translate“ the German change into a third (Czech) language: content original German and Czech translation field still appear in WPML backend. (d)
3.2. the changes in the third language (Czech) work fine: visible in frontend, and fields still available in WPML backend. So this error only occurs regarding english translation.

Long story short, it looks like the connection between the original post/page and some translations is behaving strangely. We are therefore either losing translations, whole pages, or pages have mixed content (in 2 languages).

I would appreciate if you could have a look and advise me on a possible solution.
Please feel free to let me know if you have any questions or need additional information.
The current link is a link to a staging environment (please make sure, that you stay within the kittec.eu/staging/ directory though)

Thanks & Best
Alec

June 25, 2019 at 6:15 pm #4086655

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Alec,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues. I have a couple of requests to track the issue.

1) Please allow me to deactivate plugins and switch to default theme while testing the issue

2) Please share with me the WordPress debug.log (not WPML debug information) for more details.

Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

June 28, 2019 at 4:56 pm #4109551

alecC

Hi Bigul,

thanks for getting back to me!

1) please feel free to do whatever you like within the system, as this is just a staging environment
2) Here is the log file: https://pastebin.com/SYyXmXmW
There is actually only one issue with the Wordfence firewall, so I went ahead and deactivated the plugin for the time being, but the issue unfortunately still persist. Right now some translation appear even twice within the translation editor: hidden link

Long story short, the log does not contain any WPML related issues.

Looking forward to your feedback.
Best
Alec

July 1, 2019 at 9:42 am #4117235

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Alec,

Thank you for the details and permission. Debug log is not showing any warning or error related to WPML. But the issue(first one) is existing after the initial checks.

I am not able to find the exact Page having the following problem. So please share with me the Page URL. Does it happen with only one Product?

hidden link

Also please share me the FTP credentials for further checking.

Sorry for the delay happened because of the weekend.

--
Thanks!

Bigul

July 1, 2019 at 2:22 pm
July 2, 2019 at 12:04 pm #4126553

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Alec,

Thank you for the details. The issue is existing for me after the initial debugging checks. Therefore I have forwarded the details to our second tier team for the expert opinion. We will get back to you soon. Please wait.

--
Thanks!

Bigul

July 3, 2019 at 7:13 am #4132541

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Alec,

We would like to know you have a backup before upgrading to the latest version of WPML(4.2.7). If you have a backup, please share it with us. I am enabling the private option for the next reply. Hope cross-checking the backup will help us to trace the issue.

Please let me know your feedback.

--
Thanks!

Bigul

July 3, 2019 at 3:53 pm
July 4, 2019 at 6:32 am #4140457

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Alec,

Thank you for the updates. I have shared the backup with our team for further checking. We will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

July 8, 2019 at 2:31 pm #4163537

alecC

Hi Bigul,

any news yet?

Thanks
Alec

July 9, 2019 at 2:54 pm
July 11, 2019 at 11:56 am #4189481

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Alec,

For your kind information, the bug is existing after the primary investigation steps. But it works fine when we tried with your backup on our local servers. Therefore escalating the ticket to our second tier team for further debugging. We will get back to you soon. Please wait.

--
Thanks!

Bigul

July 22, 2019 at 11:28 am #4256607

alecC

Hi Bigul, any news?

July 23, 2019 at 7:44 am #4263403

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Alec,

For your kind updates, our second tier team is still working on the issue. We will get back to you as early as possible. Please wait. Sorry for the delay.

--
Thanks!

Bigul

July 31, 2019 at 12:09 pm #4314195

alecC

Hi Bigul,

another week has passed without any movement in regards to my ticket. I must insist that your second tier support prioritizes my ticket.

Thank you for your understanding.

Alec