If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Content in Gallery is translated but doesnt show the translated content in unicode theme

Solution: https://wpml.org/forums/topic/galleries-from-uncode-theme-cannot-be-used-in-second-language/page/3/#post-4046737

This topic contains 9 replies, has 2 voices.

Last updated by sanamiB 1 month, 3 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
September 13, 2019 at 11:00 am #4567721

sanamiB

Tell us what you are trying to do?
hidden link

The image is clickable and shows on a gallery:
hidden link

The image is allready translated, but it doesnt show the translated image

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?

September 16, 2019 at 3:02 am #4575937

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

We recently released new versions of WPML plugins with fixes and improvements so could you please update the plugin to the latest version and let me know if this helps?

NOTE:

+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/

Further, Can you confirm that you are still experiencing issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Nineteen)

Look forward to your reply.

Thanks

September 18, 2019 at 6:16 am #4592663

sanamiB

Hi

I did all updates, but the problem still exists. I deactivated all plugins, exept the WPML stuff.

Still exists...

Thanks for your help
Roger

September 18, 2019 at 11:09 am #4595497

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

To debug this issue further, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

September 20, 2019 at 8:44 am #4610689

sanamiB

I have to correct me, in the sidebar widgets only the widget title: RECENT POSTS is not translated in russian.

September 23, 2019 at 3:33 am #4620091

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

For the new issue, please open a new ticket so we can debug the issue quickly and easily.

Regarding the gallery issue, can you try to create a separate gallery for secondary language and choose it accordingly in secondary language using manual editor and let me know if that works?

Look forward to your reply.

Thanks

September 23, 2019 at 9:04 am #4621867

sanamiB

Hi

I've created now a gallery in russian:hidden link

Problem, if I wanna place it inthe post: hidden link, I dont see the russian gallery in media...strange.

Thanks and best
Roger

September 23, 2019 at 9:23 am #4621929

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Can you use the solution mentioned here once and let me know if this helps?
https://wpml.org/forums/topic/galleries-from-uncode-theme-cannot-be-used-in-second-language/page/3/#post-4046737

Look forward to your reply.

Thanks

September 23, 2019 at 1:31 pm #4624587

sanamiB

Yes this would really helpfull, but its a little bit hard to red because of the hidden files:
-----
Hi Jerry,
we spotted the problem and I'll try to explain a bit. There is a quite note issue about reading the configuration file with WPML (not related to Uncode) and on Google you can find a lot of results, ex: hidden link...56309.56563..56740...0.0..0.73.214.3......0....1..gws-wiz.......0i71.Ov5GXYGdz8I

In the WPML setting if here you search for Gallery you have this: hidden link

While this should be set on "Non tradurre" (in English "ignore) and this is specified in our configuration file that is part of Uncode: hidden link

For the note issue reported above with WPML (this happens in some installations) the configuration file is ignored until you don't load it again manually or you set the correct option manually, ex: hidden link

Now you can create the 2 galleries:
hidden link
hidden link

And they work as expected:
hidden link
hidden link

Note that after the properly XML settings are applied manuelly this will work for every new gallery but not for the previously created.

Best,

David | Undsgn™ Author

September 23, 2019 at 2:40 pm #4625083

sanamiB

My issue is resolved now. Thank you!