This thread is resolved. Here is a description of the problem and solution.


ACF content is not populating any of my translation pages


It is essential to check if the fields are set correctly according to our instruction on how to work with PWML and the ACF plugin. Then it is important to update the original post and its translation.

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by austinD-3 10 months, 1 week ago.

Assigned support staff: Itamar.

Author Posts
July 29, 2019 at 4:08 pm #4301765


We are trying to translate several different languages from English.

They are all using the same template, but when I switch languages, no content appears for the French translation. I have set most of my ACF fields to copy, so they will populate, but this has not solved any of my issues.

July 29, 2019 at 4:41 pm #4302029


Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)


Can you please confirm that you are following our instructions at the following link on how to work with WPML and the ACF plugin?

Please also let me know where I can see the issue on your site.

To continue debugging this issue please first update the following.
- WordPress. You are using an old version of WordPress please update.
- ACF Pro. You are using an old version of ACF Pro please update.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

*** If your site is a live site you might want first to try those procedures in a staging environment or a snapshot of your site on your local server or another server. ***


July 29, 2019 at 4:55 pm #4302075


It seems to be that my ACF field group rules are not being copied over to my other languages, so the ACF Fields are not being applied.

Any advice with this?

July 30, 2019 at 3:44 pm #4309453


Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)


You would also need to update the translations for the fields option to be applied.
Are all your translations updated?

August 1, 2019 at 7:20 pm #4324901


My issue is resolved now. Thank you!