Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Andreas W. 12 months ago.

Assigned support staff: Andreas W..

Author Posts
December 10, 2018 at 4:13 pm #2985296

sylvainC-8

Hi,
Please we need help we getting a huge issue... we are using Beaver Builder and wpml on one of our website.

All plugins are up to date (beaver, wpml, wpml media, wpml string translation). We use our own template.

Symptom is : All translated pages were build by duplicated the original in the same language. Then we changed the language of the duplicated pages and assign them to their original pages. All worked fine !

There are few days, our client start to edit some SEO elements in the original language pages. As it was saved, the translated pages were totally replaced by the original content !!!
Of course he didn't check if all was fine with the first and he did the changes for all pages before to check... Now our client has no more translated pages (we talk about more than 130 pages !!!)

We duplcated the site on an other servor and we tried all the things possible... nothing works... we tried to disable wpml media, wpml string translation... we have spent the day and nothing works...

We saw that there is a know issue which is close to our issue. Except that for us, the translated content was delated when the original contents were changed... https://wpml.org/errata/cannot-edit-page-builder-translations-with-the-native-wordpress-editor/

Can you help us on this bug ? We really need to recover all the translated contents !!! When we disable beaver builder and changed the theme, all the content was well shown in both language... it want to say that the translated content is not erased ^^

Sincerely
Boris

December 10, 2018 at 9:04 pm #2986079

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for contacting WPML Support.

After reviewing your provided debug information I realized that you are not using the latest version of WPML, which has been released today to solve issues for sites that have been built with page builder elements.

You can read more about this issue here.

https://wpml.org/errata/when-the-translation-is-saved-some-content-is-replaced-with-the-original/

Please go to Plugins -> Add new and select the Commercial Tab. Then click "Check for Updates" at the right side of the screen. You should now be able to mark various checkboxes for WPML and its add-ons. Scroll down and click "Download". You are further able to set a checkbox right next to this button to activate the Plugins after downloading.

Further, if this update should not solve the issue, there might be another solution.

You explained that the original content had been duplicated. Please take note that duplicated content will always show up in the language of the original content unless you translate the content for the second language independently. Further, if you do not choose the option "translate independently" the duplicated content will always show up in original language once the original content receives an update.

You can find a more detailed information about this translation method here:

https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/

Please let me know if the update solved your issue.

Best regards,
Andreas

December 11, 2018 at 8:04 am #2987500

sylvainC-8

Hi andreas !
thank you for your answer.
Indeed we saw the update and we did it. We are now using the 4.1.2. I think I have create my post before the last update has been released yesterday. Unfortunately it doesn't resolved our issue...
One thing about our process of translation. We didn't use the "dupplicate" button add by wpml in the original page.
What we have done is to "duplicate" the page with the wordpress classic system. After that we opened the duplicated page, renamed it and tell her to be of an other language and to be the translated page of the original.
It is the only way we found to keep the beaver builder layout unbroken in the translated page...

I really hope that you could help us...

We activated a maintenance plugin on the debug site. If you need to see or access it, you should give me your IP.

Sincerely
Boris

December 11, 2018 at 3:54 pm #2989468

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Best regards,
Andreas

December 11, 2018 at 10:40 pm #2990598

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

After reviewing your website I realized that all the posts and pages that I checked appeared with their respective content.

The issues about displaying original content instead of translated content appears on the custom post types "Interventions" and "Areas of Treatment". Some of the content does appear correctly, other not. If you take a look at WPML -> Translation Management it appears that many content do not have any translation yet. After switching your site to a minimal setup this section were not longer available as they are related to your custom theme.

I used the default WordPress Theme TwentyFifteen and any additional plugins active that is not related to the theme. Contents appear translated on EN and FR posts and pages.

When it comes to an example in pages where the content is shown with French when it should be English I came across the page hidden link. It appears that here the English site shows French content. I assigned myself as translator in Translation Management and checked the task for this translation. It resulted that the contend had not been translated. (See screenshot attached)

For more info about translating content from Beaver Builder with WPML please read the following documentation:

https://wpml.org/documentation/plugins-compatibility/beaver-builder/

I would kindly like to ask you to use Translation Management to translate your complex page content. More info about how to use Translation Management you can find here:

https://wpml.org/documentation/translating-your-contents/

As far I inspected most content had not been translated proper. Please take a look at this page which I translated for you with Translation Management.

hidden link

Further, the proper way to duplicate content when using WPML is to duplicate the post with WPML and then after to "edit independently" on the post editor. Please read more about how to duplicate content with WPML here:

https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/

Please could you clarify more your statement that 130 pages of content disappeared after using a Yoast SEO?

Please do not hesitate to contact us for any further assistance.

Best regards,
Andreas

December 12, 2018 at 8:06 am #2991971

sylvainC-8

Hello Andeas, thank you for your answer.
I will try to clarify what has been done.

We didn't used the wpml translator managment because this system meen that the client don't have the capability to change the design of the same page between the two language. This system meens that you need to have exactly the same things at the same place for both langage.

So we decided to duplicate the french original pages to translate them independently. We tryed to use the "duplicate' button of wpml but all the content, I meen all the beaver builder template, was copyed inside the content area of wordpress... So we install a plugin to do the job of duplicated page or custom post. So for each page the system has worked fine. We duplicated the page, and then changed his language and assign them to the french version...

All the translated content has disappear after our client has made change in yoast in the original language. But it doesn't come from yoast because I created a translated page like the others and I just changed the title and the translated content has also disappear...

There is also something really strange... Did you see that when you go inside a post in the BO, the wordpress content and beaver builder area disappear ? Maybe it can be linked ?

Boris

December 12, 2018 at 9:34 am #2992302

sylvainC-8

Andreas,
I made a change in our template. Now if you disable Beaver you will see that our translated content is well shown in the content area.

Disable beaver builder (called speededitor) and look at this page for exemple : hidden link
you will see that there is a translated content. It is somewhere but not in wpml... It seems that wpml translator is used by default even if we don't want to use it... It seems that translator don't know our translated content because we didn't use it...

I look on the page that you translated with the wpml translator. If we disable beaver we retrieve our old content... but what I can see is the difference on the second screenshot. The language select seems to be "activated". If I look on a page where there is the bug, this select menu seems to not be "properly" activated... I don't know but is there a way to force him ?

EDIT : about my last post, I found that the bug of content area gone came from ACF... no reports with the translation

Boris

December 12, 2018 at 3:25 pm #2994127

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

In case of working with WPML and manual translations the correct way would be to first duplicate the original content with WPML. To edit the translation you would only need to click "Translate Independently". As you realized this would also include that you need to independently edit the page builder interface for different layouts in different languages.

You further mentioned a third plugin that was used to duplicate content to avoid the duplication procedure of WPML. It might be that this plugin caused incompatibility between the content and WPML, but I am further more sure about that the custom theme might be the issue here, as the content appears when the custom theme Beaver Builder plugins are disabled.

At this point I would suggest you consider contacting one of our certified partners from this link: http://wpml.org/documentation/support/wpml-contractors/

I'm sorry I am unable to provide an easier solution for you, but I hope this helps point you in the right direction.

Best regards,
Andreas

December 14, 2018 at 9:45 am #3001111

sylvainC-8

Andreas,
We made last update of WPML and all his plugins. Now, when we save french version of content, the english version is not replace by the french (whatever the way it was translated). It's a good news ! But all our old content is not come back.
When we go to "Revisions" of an English post the content is show in English but no on front. It seems that we are not alone with this issue : https://wpml.org/errata/when-the-translation-is-saved-some-content-is-replaced-with-the-original/ lookt at the post of Ghio on December 13, 2018 at 7:09 am.

We really need to find a way to get back our already translated content (130pages !!!).

December 14, 2018 at 10:21 pm #3003192

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Do I understand right that after updating WPML to the latest version you are able to edit and save older content that now appears in its respective language language on the frontend but this does not work for the post type "Revisions"?

Did you try to edit and save those posts? Do those translations still appears in the original language after updating them? Could you maybe try to edit a SPACE behind the title of your revisions and to update the content to see if this fixes the issue on frontend? I know it might be a lot of work to go through 130 revisions but it would be good to know if this workaround might solve your problem.

Please let me know if this fixed your issue.

Best regards,
Andreas

The topic ‘[Closed] Content translated disappear !’ is closed to new replies.