This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Laura 4 months, 1 week ago.

Assigned support staff: Laura.

Author Posts
May 31, 2019 at 11:20 pm

grazynaD

I am trying to:
Set the configuration; choose who will translate the page: Admin, Users, Service, Contractors.
(I want to choose Admin and Users

Link to a page where the issue can be seen:
It happens in the admin panel.

I expected to see:
Next step.

Instead, I got:
Dead button. The site is not even loading.

June 3, 2019 at 1:58 pm #3943099

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

Please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

Browse to the page with the issue and/or reproduce the issue.

Locate the debug log in: /wp-content/debug.log

Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

I would also need your WPML debug information. You can find it in:
WPML -> Support -> click on debug information link
Then you can copy/paste the text you see in the Debug box I'll enable for the next answer.
More information here: http://wpml.org/faq/provide-debug-information-faster-support/

June 6, 2019 at 10:51 pm #3972377

grazynaD

Hi, I have had problems with achieving wp-content folder from my server provider. Though I installed a plugin, which adds the code providing the debug info. Hope that will work. If not I will contact the provider in order to do that properly. Please, chack what we have.

June 7, 2019 at 10:13 am #3975493

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

from your debug information, I can see the WP Memory Limit needs to be increased. PHP memory limit is fine but WordPress uses 40Mb as default. Minimum requirements for WPML are 128Mb.
Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );

The wp-config.php file is located in your WordPress root directory. It's the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.
You can check the current WP Memory Limit value from WPML -> Support in the Info section
More info here:
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
https://wpml.org/home/minimum-requirements/

You can also try a compatibility test:
- backup your site
- disable all plugin except WPML and its addons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again

If you'd manage to check the error log it would be useful. You may also try to contact your hosting for the server error log, probably it still has some useful information.

June 7, 2019 at 6:51 pm #3978595

grazynaD

Hi, I managed to include those lines in wp-config.php, but the bug still occurs. The memory is set to 256.

June 7, 2019 at 7:38 pm #3978867

grazynaD

I disabled all plugins but WPML ones and the bug still occurs.

June 10, 2019 at 10:05 am #3986547

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

did you manage to retrieve the debug.log as I explained here? https://wpml.org/forums/topic/continue-button-in-translation-management-first-configuration-does-not-work/#post-3943099

Since apparently there aren't other errors this is the only thing I can rely on.
Otherwise, if you didn't translate anything yet, you can try to reset WPML in WPML -> Support -> troubleshooting, but please be sure to take a backup first.

The topic ‘[Closed] "Continue" button in Translation Management first configuration does not work.’ is closed to new replies.