This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Is there any filter where I can set that enable/disable the appearance of currency switcher?

Solution: We don't have any filters where you can directly set enable/disable for the currency switcher.

Depending upon the cases you can create a custom currently switcher accordingly, https://wpml.org/documentation/related-projects/woocommerce-multilingual/multi-currency-support-woocommerce/

Relevant Documentation:

This topic contains 2 replies, has 2 voices.

Last updated by zsoltE-2 1 year ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
September 26, 2018 at 8:24 am #2766423

zsoltE-2

Tell us what you are trying to do?
There are some cases, when I want to hide currency switcher on Woocommerce product page.
is there any filter where I can set that enable/disable the appearance of currency switcher?

September 27, 2018 at 11:29 am #2770289

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

Depending upon the cases you can create a custom currently switcher, https://wpml.org/documentation/related-projects/woocommerce-multilingual/multi-currency-support-woocommerce/

Further, you can find a list of WCML hooks here, https://wpml.org/documentation/related-projects/woocommerce-multilingual/wcml-hooks-reference/, I haven't tested this but if you use the following hook https://wpml.org/wcml-hook/wcml_currency_switcher/ and create some custom code, you can control the display.

Being said so we don't have any filters where you can directly set enable/disable for the currency switcher.

Thanks

October 1, 2018 at 1:52 pm #2778339

zsoltE-2

My issue is resolved now. Thank you!