This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
Where do I translate the Cookie Notice created using "Cookie Notice Version" plugin

Solution:

1) Copy the following code in WPML->Translation Management -> Custom XML configuration

	<wpml-config>
		<admin-texts>
			<key name="cookie_notice_options">
				<key name="message_text"/>
			</key>
	  </admin-texts>
	</wpml-config>

2) Once you place the code there, go to WPML->Translation Management -> Multilingual content setup and refresh the page.

Once you have created language configuration files you need to go to WPML->String Translation and search the strings that you have inserted in the theme options and translate it into the secondary languages.

Relevant Documentation:
https://wpml.org/documentation/support/language-configuration-files/

This topic contains 2 replies, has 3 voices.

Last updated by florianE-6 1 year, 5 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 9, 2018 at 8:30 am #2046810

larsK-17

Tell us what you are trying to do?

Where do I translate the Cookie Notice for my english version of the site?
I'm using the plug in "Cookie Notice Version 1.2.42 | of dFactory ".

What is the link to your site?

hidden link

Thanks, Mirco

May 10, 2018 at 3:31 am #2064848

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

So, in order to translate the admin texts (Theme Options Fields) you need to create a language configuration file. Please follow the below steps:

1) Copy the following code in WPML->Translation Management -> Custom XML configuration

<wpml-config>
    <admin-texts>
        <key name="cookie_notice_options">
            <key name="message_text"/>
        </key>
  </admin-texts>
</wpml-config>

2) Once you place the code there, go to WPML->Translation Management -> Multilingual content setup and refresh the page.

To find out more, https://wpml.org/documentation/support/language-configuration-files/

Once you have created language configuration files you need to go to WPML->String Translation and search the strings that you have inserted in the theme options and translate it into the secondary languages.

Let me know if this helps.

Thanks

August 7, 2019 at 6:46 am #4352321

florianE-6

It looks like this solution doesn't work anymore. I followed instruction and I get the final string to translate but that new translation can't be displayed.

I'm not sure should I add or generate some kind of XML file into theme or plugin folder. Just in the admin window, it looks fine but on page, everything is the same. I can also see on Cookie Notice plugin page that other users have the same problem.

Regards!