This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Vincenzo 1 year ago.

Assigned support staff: Vincenzo.

Author Posts
October 1, 2018 at 2:15 pm

davidD-32

I am trying to: translate the page, using the copy or overload content option

Link to a page where the issue can be seen: hidden link (in the back office)

I expected to see: all my ACF fields in the back office already filled with the content from my primary language

Instead, I got: the page with no ACF field and no content at all.

I already used this technique on several websites with no problem at all, but here I can't make it work and i don't know why since I have the same settings on the same environment.

Thanks for your help, it's rather urgent 🙂

October 3, 2018 at 4:39 pm #2785293

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, thank you for contacting WPML Support!

Can you please take a look at this documentation and verify if all the steps have been followed?
- https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

It is important to install the Advanced Custom Fields Multilingual plugin.
- https://wpml.org/account/downloads/

Please let me know if this solves the issue or if you need further details.

Thank you

October 8, 2018 at 9:51 am #2795414

davidD-32

Hello!
Thank you for your answer! Unfortunately, it didn’t solve the problem.

I’ve installed all the plugins I think that are necessary including Advanced Custom Fields Multilingual.
The list :
- WPML Media
- WPML Multilingual CMS
- WPML Sticky Links
- WPML Sticky Links
- WPML Translation Management
- WPML Translation Management

Then I’ve tried all the settings possible for “Custom Fields Translation”, which are “No translate”, “copy” and “Translate”. None of these settings made a difference.

I have currently set all the custom fields to “Copy” since it's what I want to do.

What I am trying to do is translate a page with custom fields from French to English and keep the same custom fields in the English version. I don’t want to translate the label or name of the fields but only its value.

Here’s the problem:

1) I go on my page in French. You can see that all the custom fields are filled.

2) Then I click on the blue “Plus” Translate. It brings me to my page in English. Then I click on “Overwrite with French content”.

3) The custom fields aren’t copied. The page has the right template but no fields.

If I create a page directly in English and I set the template, the custom fields don’t appear.

I’ve figured out that the problem comes from the fact that all my ACF custom fields aren’t copied in the English version of the website. I’ve tried all the settings available for custom fields translation, nothing works.

It’s not the first time we use WPML with ACF and usually, it works perfectly without having to change any setting.

I hope my message is clear and we will be able to find a solution.

Thanks for your help.

October 8, 2018 at 5:17 pm #2797009

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

can you please try setting the Groupes de champs (acf-field-group) to "Non traduisible" from WPML -> Paramètres -> Traduction des types de publication?

Please let me know if this solves the issue or if you need further details.

Thank you

Related documentation:
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#1-checking-translation-options

October 9, 2018 at 9:10 am #2799084

davidD-32

Hi again!

I reinstall all WPML plugins on my website and delete every try of translation in order to start with a clean base.

My settings for ACF are set in “No Translation” (see screen capture below). Now, my ACF fields are copied in English.

But now the problem is: when I try to copy or overload content, it copies the field but not the French content inside.

October 9, 2018 at 5:11 pm #2801324

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

this probably happens because the Custom fields are set to "Don't translate".

Can you try setting the single custom fields according to your needs (Copy, Translate, etc.)?

See: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#making-acf-fields-translatable

October 10, 2018 at 8:28 am #2803399

davidD-32

Good Morning!

Indeed, now my Custom Fields are set to “Copy” and the page translation works.
But I’m now stuck on another problem: I need to be able to translate one ACF field group, but I want the others to be automatically copied.

That what cause my bugs in the first place.

If I set the field groups as “No translatable”, I can’t translate any (which sound normal). But if I set the field groups as “Translatable” (I’ve tried both parameters), I must manually translate/copy all my fields groups when I only want to translate one.

Is it possible to copy all field groups automatically and just translate one?

PS : By the way, it's very irritating to have to check every checkbox independently in the Custom Fields Translation parameters, especially when you have a hundred custom fields like me, is very long and annoying. Why don't put the possibility to check all checkboxes at once with a button?

October 10, 2018 at 11:53 am #2804083

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

you may try following these steps:
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#translating-field-groups

Only, instead of setting the Field Groups (acf-field-group) to "Translatable – only show translated items", try setting it to "Translatable - use translation if available or fallback to default language".

❌ IMPORTANT ❌
Please note that this solution is not tested and I suggest trying it on a development version of the site (staging site) and after a full backup.

About the feature request to bulk select the translation option of all the custom fields, I will ask, but this may be rejected because setting all the custom fields to the same option may cause some issue with custom fields coming from other plugins or from the theme.

You may also hire a contractor to help to code a custom solution.
For this, we recommend contacting one of our certified partners.
Please check the link below:
https://wpml.org/contractors/

Best regards,
Vincenzo

October 10, 2018 at 12:39 pm #2804262

davidD-32

I tried "Translatable - use translation if available or fallback to default language". It doesn't work. Meaning, it doesn't copy automatically all ACF field groups and then lets me translate the one I need.
This feature would have prevented me of copy manually all my field groups.
It’s a shame this feature doesn’t exist. It would save a significant time for everyone who need to translate just a few labels that are displayed on the front-end.

Anyway, I’m going to do another way.

Regards

October 10, 2018 at 4:33 pm #2805209

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

I'm sorry that the workaround didn't work.

Please let me know if you need any further assistance and I will be happy to help.

Kind regards,
Vincenzo