This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 20 replies, has 3 voices.

Last updated by ahmedM-19 5 months, 2 weeks ago.

Assigned support staff: Lauren.

Author Posts
March 18, 2019 at 6:00 pm

ahmedM-19

I am trying to:

Link to a page where the issue can be seen:

I expected to see:
I only need to translate business name, city, location and telephone.

March 18, 2019 at 7:11 pm
March 18, 2019 at 7:27 pm #3372701

ahmedM-19

Did you go for migration

March 18, 2019 at 8:02 pm
March 18, 2019 at 8:03 pm #3372991

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I have sent you a private reply. Please let me know when the migration is completed and I will continue troubleshooting there. Thanks!

March 19, 2019 at 9:29 am #3377223

ahmedM-19

Hi Lauren,

Migration is completed.
hidden link

Thank you

March 19, 2019 at 4:53 pm #3381749

ahmedM-19

Hi Lauren,

Something very weird is happening.
I adjust custom fields in the classic translator to have only business name,city & telephone to appear like this one in the screenshot: hidden link

While I am surprised that some businesses transferred to translations with all these fields as in this screenshot: hidden link

Waiting for a solution.
Thanks
Dodd

March 19, 2019 at 9:47 pm #3383619

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I was able to set up a copy of your site locally and reproduce the issue. I am consulting with our developers now to see if we can figure out why this is happening. I notice it is also happening when you create new posts, not only on older posts. I will update here as soon as I have more information. Thanks for your patience.

March 20, 2019 at 2:31 pm #3389083

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I have escalated this to our 2nd Tier Support team. I will be working with the developers to find a resolution and will keep you updated here. Thanks for your patience while we continue to troubleshoot.

March 24, 2019 at 10:33 am #3448097

ahmedM-19

What is happening!!!
Is there anyone to support, Lauren!!!

March 25, 2019 at 1:01 pm #3453709

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Yes, our developers are currently working on this issue and I expect to have an update for you soon. I'll post here just as soon I hear from them.

March 27, 2019 at 3:29 pm #3472705

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Our developers found that the custom fields need to be added to WPML -> Settings -> Custom XML Configuration in order to show up in the translation editor. The phone number fields were not displaying because by default, any field that contains only numbers is not sent to translation. So as a workaround, you can simply add some character other than the number to the phone number field. For example, instead of 1234567890 you would add the value as 1-234-567-8900 and then it will display in the translation editor. If you don't actually need to translate the phone number, you can set it to copy instead of translate in the xml configuration. Here is what was added in the test site:

<wpml-config>
    <custom-fields>
        <custom-field action="translate">wyz_business_phone1</custom-field>
        <custom-field action="translate">wyz_business_excerpt</custom-field>
        <custom-field action="translate">wyz_business_phone2</custom-field>
        <custom-field action="translate">wyz_business_slogan</custom-field>
    </custom-fields>
</wpml-config>

You can test this in action in the cloudways staging site. I confirmed that the custom fields now show up on the translation editor.

Please let me know if you need any further assistance and I will be happy to help.

March 29, 2019 at 6:24 pm #3493871

ahmedM-19

Hi Lauren,
Thank you for your response.

I followed your steps and write in Custom xml configuration but only business title, city and phone 1 appeared.
I need phone 2, Logo and location to appear..
You can check these screenshots:
hidden link
hidden link

What shall I do!!!
Waiting for your feedback
Thanks

March 29, 2019 at 7:35 pm #3494497

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
My name is Carlos and I will be taking this ticket because our colleague Lauren is off today.

I have added the requested fields to the XML code and now the code looks like this:

<wpml-config>
    <custom-fields>
        <custom-field action="translate">wyz_business_phone1</custom-field>
        <custom-field action="translate">wyz_business_excerpt</custom-field>
        <custom-field action="translate">wyz_business_phone2</custom-field>
        <custom-field action="translate">wyz_business_slogan</custom-field>
        <custom-field action='translate'>business_gallery_image</custom-field>
        <custom-field action="translate">wyz_business_location</custom-field>
    </custom-fields>
</wpml-config>

Could you confirm that the issue is solved?

Regards,
Carlos

March 31, 2019 at 12:10 am #3499499

ahmedM-19

Hi Carlos,

I saw the code you wrote in XML code and tried the translation editor.
For new business transferred from the basket, Location field is missing while for businesses exist in translation, business tags appeared and location also is missing.

Thank you,
Dodd