This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: WooCommerce Coupon feature is not working in secondary language

Solution: The issue was happening because of a miss configuration. We don't need to translate the woocommerce_enable_coupons settings option. The Coupon code field is showing for me when I mark this String as *Not translated*.

Relevant Documentation: https://cdn.wpml.org/wp-content/uploads/2018/09/2776276-2018_09_30_1336.png

https://cdn.wpml.org/wp-content/uploads/2018/09/2776276-2018_09_30_1335.png

This topic contains 9 replies, has 2 voices.

Last updated by willemM-2 1 year ago.

Assigned support staff: Bigul.

Author Posts
September 21, 2018 at 9:53 am #2754777

willemM-2

Made two coupons in Woo, English, and Finnish. English is ok, but Finnish is not showing at all.

September 24, 2018 at 2:33 pm #2760788

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

September 25, 2018 at 10:05 am #2763319

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. It may be happening because you have opted *Translation* for the *Coupons* post type. Please choose *Not translatable*(by default in settings) as translation preference for the *Coupons* post type(from WPML>>Settings>>Post Types Translation). Then make sure the issue is existing or not.

Please check the attached images for more details and let me know your feedback.

--
Thanks!

Bigul

September 25, 2018 at 12:39 pm #2763767

willemM-2

I did not work, I see the coupon field in the Englisch language but not in Finnish

September 25, 2018 at 4:17 pm #2764739

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Maybe you are facing this issue because of compatibility conflicts. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate the plugin one by one to see with which one there is an interaction issue

Also, please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

September 25, 2018 at 5:21 pm #2764839

willemM-2

Hi Bigul,
You have my permission to copy the site with duplicator to find the problem. I did all the things you asked already, I am lost, I don’t know were to look further.
I will try again tomorrow and do it all over again, step by step to see if I get another result.
Hope you have more luck to find it.
Have a nice day

September 26, 2018 at 8:34 am #2766472

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. I have downloaded Duplicator copy of your site now. Will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

September 27, 2018 at 8:19 am #2769698

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, the issue is existing in my local server copy after the initial debugging steps. But I am not able to reproduce the issue in a fresh installation. So I have forwarded the details to our second tier team for the expert opinion. We will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

September 30, 2018 at 8:11 am #2776276

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind information, the issue was happening because of a miss configuration. We don't need to translate the woocommerce_enable_coupons settings option. The Coupon code field is showing for me when I mark this String as *Not translated*.

Please check the attached images for more details and let me know your feedback.

--
Thanks!

Bigul

October 1, 2018 at 8:25 am #2777370

willemM-2

My issue is resolved now. Thank you!