Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 7.22 hours from now. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- - 9:00 – 18:00 9:00 – 18:00 9:00 – 18:00 9:00 – 18:00 9:00 – 18:00
- - - - - - -

Supporter timezone: America/Lima (GMT-05:00)

Tagged: 

This topic contains 25 replies, has 2 voices.

Last updated by Andreas W. 1 month ago.

Assisted by: Andreas W..

Author Posts
February 13, 2024 at 9:35 am #15296320

axelL-4

In the WP search form, CPTs remain untranslated as a filter (see screenshot). Why is this happening?

I went through the whole tutorial (https://wpml.org/documentation/getting-started-guide/string-translation/finding-strings-that-dont-appear-on-the-string-translation-page/#enable-auto-register-strings), but I could not find the solution...

Pasted Graphic.png
February 13, 2024 at 6:21 pm #15299172

Andreas W.
Supporter

Languages: English (English ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Is this a feature of the Themify Ultra Theme?

If so, I can offer a WPML test site, so that we can try to replicate the issue and escalate it internally, in case I will not be able to find a quick solution.

Would you be able to install the Themify Ultra Theme on such a test site?

Best regards
Andreas

February 13, 2024 at 7:08 pm #15299284

axelL-4

Hi Andreas, yes that would be great! Where can I find the test page?

February 13, 2024 at 8:51 pm #15299541

Andreas W.
Supporter

Languages: English (English ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Please use this link and leave me a short message once the theme and its plugins are installed.

One-Click-Login:
hidden link

February 13, 2024 at 9:27 pm #15299713

axelL-4

Would it be possible to give you access to a staging copy of my actual site instead? You could do whatever you want there (disable plugins, change settings etc) and I would not have to install all the different plugins and set everything up. Would that be possible?

February 13, 2024 at 9:55 pm #15299754

Andreas W.
Supporter

Languages: English (English ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Yes, it would be great to first revise the issue on a staging site, but if I can confirm the issue on a minimal setup and there is no way to translate those strings, then we will need to try to recreate the issue from scratch, to confirm that it is a general issue.

Otherwise, I will not be able to escalate the issue internally and we will not be able to inform the author about the issue.

I would like to offer to have a closer look at the problem and request temporary access to your staging site (wp-admin) to the website to investigate this issue further. The FTP access is not mandatory in this case.

You can find the required fields below the comment section when you log in to leave the next reply. The information you provide is private, which means only you and I can see and access it.

IMPORTANT
Please be sure to make a backup copy of the website and database before allowing us access.
If you can't see the wp-admin / FTP fields, your post and website credentials are set as PUBLIC. DO NOT publish the data unless you see the required wp-admin / FTP fields.

The private response form looks like this:
hidden link

Next time you reply, click "I still need assistance."

Video:
hidden link

Please note that we are obliged to request this information individually on each ticket. We may not access any access information not specifically submitted on this ticket in the private response form.

February 14, 2024 at 11:17 am #15301600

Andreas W.
Supporter

Languages: English (English ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

I can see the translation works in German, which is why it is odd that it does not work in German.

Could you please try to go to Post Type Builder > Post Types, then switch the language inside the top admin bar and edit each post type in each language manually?

February 14, 2024 at 11:30 am #15301707

axelL-4

Yes, this seems to work. But I am not sure if I am doing the right thing. Can you check my screenshot?

SCR-20240214-lfix.png
February 14, 2024 at 11:38 am #15301804

Andreas W.
Supporter

Languages: English (English ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Yes, you could also try to translate the slug.

The slug is part of the URL when viewing a book post in Korean in this case.

February 14, 2024 at 1:30 pm #15302578

axelL-4

It does not seem to work... can you check my screen cast: hidden link

February 14, 2024 at 3:53 pm #15303367

Andreas W.
Supporter

Languages: English (English ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

I ran a few more tests on your staging site, but I can not manage to translate those strings inside the search dialog.

The search seems not to filter content by language and it seems to me that the filters show up dynamically based on the found content and fall back to the site's default language.

If you go to Korean for example and search for "test" you see English books available in Korean. You do not have any translated book available in Korean. I have now set the post type "books" inside the WPML Settings as translatable.

I would suggest you translate the "Book" posts and then we test again.

February 14, 2024 at 6:28 pm #15304158

axelL-4

I do not get any results if I enter “test” in the Korean search form (s. screenshot)… or am I getting you wrong?

What do you mean by: "I would suggest you translate the "Book" posts and then we test again."

SCR-20240214-qycr.png
February 14, 2024 at 10:10 pm #15304513

Andreas W.
Supporter

Languages: English (English ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Yes, this is weird, as I can not longer confirm the mixed search results.

Please revise the list of your "Book" posts. I have marked the post type as translatable. Your books are not yet translated. They are all assigned to English. You can change the source language for each book on the top of the right sidebar of the WordPress Editor.

For example, I have now assigned "Der Inner Mensch" to German, as it has German content.

I was able to find more similar strings at WPML > String Translation > Translate texts in admin screens.

It seems to work now in German, but not in Korean or Arabic.

As the issue remains, when I test your staging only with Themify Ultra and its plugins and WPML I would suggest again that I send you a link to a test site, on which you install the theme and its plugins, and I will try to recreate the issue to escalate it internally to the compatibility team.

Would this be possible?

February 15, 2024 at 8:30 pm #15309355

axelL-4

Yes, please send me the link to the test site and I will try to reproduce the problem. To ensure efficient use of time, I'll spend a maximum of 1 hour on this task. If I am unable to reproduce the problem within this timeframe, I would appreciate it if WPML could investigate the matter further using the staging site.

As a paying WPML customer, I expect support to proactively address and resolve issues arising from potential bugs or unintended behavior within the WPML plugin. Of course, I am willing to assist in this process to a reasonable extent, but ultimately it should not be on me to do what I am paying for. However, I trust that WPML will take the necessary steps to ensure a quick resolution.

February 15, 2024 at 9:14 pm #15309511

Andreas W.
Supporter

Languages: English (English ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

I had sent a link to a test site two days ago. It is still active:

One-Click-Login:
hidden link

I only need you to install the Themeify Ultra Theme and the plugins that come with the theme (all in their latest available versions).

You do not need to recreate the issue, as I will run those tests for you.

Please leave me a short comment on this ticket, once the components are installed.

The topic ‘[Closed] CPTs remain untranslated in front end in search’ is closed to new replies.