This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.


This topic contains 1 reply, has 2 voices.

Last updated by Diego Pereira 1 year, 2 months ago.

Assigned support staff: Diego Pereira.

Author Posts
April 28, 2019 at 8:39 pm


I am trying to: Change the website language and it takes ages. Also it take a long time that page loads and that another page opens.

Link to a page where the issue can be seen: hidden link

I expected to see: Fast website.

Instead, I got: Very slow website. Check the attached picture. I asked out Host to provide better server, they doubled it today (as you can see from the image), but the situation is the same.

April 29, 2019 at 7:29 pm #3706305

Diego Pereira

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @tilens, welcome to the WPML support Forum!

This issue may be related to WCML. We released a new update today (WCML fixing some performance issues. Could you please update it on your website and check if the issue persist?

Here is some tips on how you can also improve performance on some points:
- Check if your server meet the minimum WPML/WordPress requirements

Please take a look at this article to see how to optimize your website with WPML:

Please go to WPML > Support >Troubleshooting and click on "Recreate ST DB Cache tables", after that visit the pages of the website a few times to recreate the cache tables.

Please check auto-registered domains in WPML > String Translation and make sure that all domains are included.

Also, disable the following settings:
- Adjust IDs for multilingual functionality (WPML > Languages)
- Track where strings appear (WPML > String translation)

Please let me know if it worked for you.

All the best,