If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 3 voices.

Last updated by matijaP 6 months, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
April 26, 2019 at 4:50 am #3687635

matijaP

I am trying to: lower cpu usage

Link to a page where the issue can be seen: hidden link

I expected to see: lower cpu usage when the plugin is off

Instead, I got: i got high cpu usage

April 26, 2019 at 12:20 pm #3690583

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

We have released a new version for WooCommerce Multilingual(4.6.2) today. Please upgrade to the latest version after a site backup and check is there any difference in the site performance.

If the issue exists, please deactivate WooCommerce Multilingual and WPML Translation Management should be activated, then check is there any difference in the site performance.

Which type of hosting service you are using, shared or VPS or Dedicated?

--
Thanks!

Bigul

April 26, 2019 at 7:56 pm #3693145

matijaP

Hi,
thank you fro your reply.
I updated to latest version of WooCommerce Multilingual and maybe it help a little but not completely. There were not so much peaks to 100% but procesor use was still around 30 -50% which is not normal.

I testet with plugin WPML Translation Management turned on but WooCommerce Multilingual turned off. Now immediatelly procesor use dropped to almost 0%.

We're using Cloud VPS with SSD disks, 4GB ram and 4x CPU 3.3Gz.

Let me know how to proceed further to fix this issue.

Thanks!

April 27, 2019 at 11:34 am #3695317

simonD-12

For your info, I have exactly the same problem...

Needed to revert back to Woocommerce 5.8 and also older Woocommerce Multilingual after my website was down for 6hours because of CPUs at 100%.

April 27, 2019 at 5:38 pm #3696013

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I have a couple of requests to track the issue.

a) Please activate the Query Monitor plugin when WPML Translation Management and WooCommerce Multilingual is active. Then check you are getting any slow queries.

b) Please share with me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

April 28, 2019 at 4:01 pm #3698487

matijaP

Hi there here are the items that you requested, first is the wordpress debug file, here is the link below:

https://pastebin.com/raw/eTtfpBEY

Second the slow queries we are getting attached in the photo below, thanks

April 29, 2019 at 2:38 pm #3704459

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. *Debug.log* is not showing any warning or error related to WooCommerce Multilingual or WPML.

We have released a new version of WooCommerce Multilingual today and it has included the fixes for the performance improvements. So please upgrade to the latest version(4.6.2.1) after a site backup and check the is there any difference.

https://wordpress.org/plugins/woocommerce-multilingual/#developers

--
Thanks!

Bigul

April 29, 2019 at 4:27 pm #3705571
matijaP

Hi,
with the updates this looks to be fixed. I will check it during the week if really works out.

But we still get slow query. Can this be fixed?

SELECT DISTINCT s.id, s.name, s.context, st.status, s.gettext_context, st.value AS tra, st.mo_string AS mo_string, s.value AS orig
FROM wp_icl_string_pages sp
INNER JOIN wp_icl_string_urls su
ON su.id = sp.url_id
INNER JOIN wp_icl_strings s
ON s.id = sp.string_id
LEFT JOIN wp_icl_string_translations st
ON s.id=st.string_id
AND st.language=su.language
AND s.language!=su.language
WHERE (su.language='sl' and su.url='[^/]+/([^/]+)/?$') or (su.language='sl' and su.url IS NULL)
+
WPML_ST_Page_Translations_Persist->get_translations_for_page()
Plugin: wpml-string-translation 2721 0,0921

New threads created by Bigul and linked to this one are listed below:

https://wpml.org/forums/topic/split-slow-quires-from-wpml-string-translation/

April 30, 2019 at 6:15 am #3708123

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Happy to know the major issue is fixed now.

This query is coming from WPML String Translation plugin and looks different from the main issue. So I have opened a new ticket for this one. Because as per our support policies, we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket.

I will get back to you soon on the new ticket. Please wait. Thank you for your understanding.

--
Thanks!

Bigul

May 3, 2019 at 3:31 pm #3736097

matijaP

My issue is resolved now. Thank you!