This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 11.52 hours from now. Thank you for your understanding.

This topic contains 7 replies, has 2 voices.

Last updated by Andreas W. 4 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
June 3, 2019 at 4:52 pm #3944625

peterV-81

I am trying to: replace english vimeo video embed code with Japanese video embed code

Link to a page where the issue can be seen:

I expected to see: japanese version of video (works for 5 seconds, then hangs)

Instead, I got: a crash. Am I not suppose to change code directly in the Beaver Builder template?

June 3, 2019 at 9:09 pm #3946215

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Please avoid to use manual translation on the WordPress Post or Page Editor when working with page builders.

Did you try to translate the URl with the WPML Classic Translation Editor or the Advanced Translation Editor? Is the field available for translation?

https://wpml.org/documentation/plugins-compatibility/beaver-builder/
https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/

Further, could you please increase your Memory Limit (php.ini) to 512M and the WP Memory limit (wp-config.php) to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 256M
WP Memory Limit 128M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and not other plugins installed.

Kind regards
Andreas

June 3, 2019 at 9:43 pm #3946259

peterV-81

Hello Andreas,

The video isn't very helpful. I need to know where to go for replacing video embed code. WPML was able to generate all the words/text in which I went in and dropped in the Japanese text. That was not a problem. I need to know where do i go to replace the english video embed code with the japanese video embed code? Because doing it via beaver builder on the front end doesn't hold the new code. It reverts back.

June 3, 2019 at 10:34 pm #3946375

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am sorry to hear that you are still experiencing issues with the translation.

Please enable one of our translation editors and translate again.

1) Go to WPML -> Settings -> How to translate posts and pages.
2) Enable the Classic WPML Editor
3) Translate the page again.
4) Fill out all the necessary fields and mark the translation as completed.
5) Verify at the bottom of the page that the translation status has 100% and mark it as completed.

Did the URL for the video appear inside of the translation and is it now translated?

Please avoid to use the fornt end editro when translating with WPML.

Kind regards
Andreas

June 3, 2019 at 10:39 pm #3946377

peterV-81

Andreas,

I've already Translated the page twice. The URL's are NOT appearing upon translating the page. Everything appears like titles and blocks of text. I was able to even replace an image for japenaes only via front page. That worked nicely. However, I am asking you if there is another method that is not listed or shown for video links??? I've watched 2 of your tutorials and I don't see an example of how a video embed code is replaced. This is very frustrating.

June 3, 2019 at 10:59 pm #3946387

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

June 4, 2019 at 6:34 pm #3954521

peterV-81

I do not feel comfortable allowing access. In one of your other forums, it looks like someone had a similar issue and your tech (Itamar) recorded a video on how to replace the embed code for video. However, the link was private. All I need from you is to UNDERSTAND where do I go to REPLACE the EMBED VIDEO "CODE"????. That's it! Can you please show me? I already understand how to replace text and images through the translation functions. That is simple and straightforward. The issue is the EMBED CODE. There is nowhere on the backend to replace the code. So the only way i've done it is through beaver builder FRONT end panels. Can you confirm that is the ONLY method? IF not, then please SHOW ME. If you do not know, then please elevate this issue to your supervisor.

June 4, 2019 at 6:55 pm #3954721

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

The recommended way to translate Beaver Builder with WPML is by using one of our WPML Translation Editors. Anyhow, it would also be possible to edit the translated page manually. You explained that you did that and that the video is canceled after some seconds, did I understand that right?

In case the fields for the video URL does not show up by default we might be handling with a compatibility between WPML, Beaver Builder or even a third plugin.

Could you please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true);
define( 'WP_DEBUG_DISPLAY', false);

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

You will be able to see errors on front end, backend and further find a complete report inside of your wp-content folder. Look for a debug.log file and provide me the results.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Please further take note that we are only able to assist if we receive access to the website. Alternatively I can offer you to provide a donwload link to a Duplicator Package and i will have a look myself at the issue on my local environment.
https://wordpress.org/plugins/duplicator/

Kind regards
Andreas

Kind regards
Andreas

The topic ‘[Closed] crashes when i replace video vimeo code for JA video in Beaver builder’ is closed to new replies.